alpha doesn’t display in shaman

This topic contains 3 replies, has 3 voices, and was last updated by  Gordon 8 years, 5 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29812

    artdrew
    Member

    I’ve converted several PNG’s into all the PVR formats that support alpha, but the alpha is not displaying in Shaman, or the Oolong iPhone emulator. It looks great in TexTool tho, and even if I display the properties of the PVR in Shaman, it shows the alpha propoerly (albeit in TexTool).

    We’re using Open GL ES1 and most often, exporting to the RGBA 8888 format.

    #33093

    Xmas
    Member

    We’re working on adding support for flexible blend modes to PVRShaman for the next release. Unfortunately right now you can only set the opacity for the entire material.

    #33094

    artdrew
    Member

    Good to know.

    Should this be true on the iPhone hardware as well?

    #33095

    Gordon
    Moderator

    To see the effects of the alpha channel you need to enable blending in your application, without this the alpha information will be ignored in most cases. In PVRShaman (at the moment) blending is only enabled when the opacity of the material using the texture is set to less than 1.0 which is why you’re not seeing transparency.

    In your own application you can specify a blend mode and enable blending whenever you want. This should work in the simulator and on the iPhone and should behave in a similar way on each (if it doesn’t you may want to file a bug with Apple). Note that we advise you to render opaque geometry first in the frame then render any transparent polygons afterwards for performance reasons.

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.