android rendering issues

This topic contains 5 replies, has 2 voices, and was last updated by  Ex3n 2 years, 8 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #31948

    Ex3n
    Member

    We have an app that is working on ios web and android. the system is working great on all three except for non powervr android devices. the rendering is getting messed up around the seams of our model it looks like a depth issue but I have been unable to find the settings to fix it. we have tried this on a nexus s (which it works on) and nexus 5,6, and 7. all of the devices that are not powervr chips are showing the exact same problem. if there are any ideas i would love to hear them thanks.

    #39391

    PaulL
    Admin

    Hi,

    Could you provide a little more detail about the issue? Screenshots in particular would be useful.

    If this would be confidential information that can’t be shared publicly, you can create a support ticket here: https://pvrsupport.imgtec.com/new-ticket

    Thanks,
    Paul.

    #39392

    Ex3n
    Member

    PaulL,

    thanks for the info. I have saved two pics. one is the heart on a nexus 6 with the area of concern. the other is on the older nexus s and is the way we would like it to look. both are running the same apk. the same engine is being used on ios and the web as well with no issues. thanks again for the help.

    https://drive.google.com/file/d/0Bx_ZJ9aSpBjoUDc2QXQzNmVjZVE/view?usp=sharing

    https://drive.google.com/file/d/0Bx_ZJ9aSpBjoUTJmVk15SmlFUG8/view?usp=sharing

    #39393

    PaulL
    Admin

    Since the issue is present on both platforms with differing levels of subtlety, I’d guess it’s a z-fighting issue where the two sub-objects of the heart meet.

    Ideally, render the heart as a single object and make sure parallel edges share the same vertices. If that isn’t feasible, minimise the distance between the near and far clip planes, this will maximise floating-point precision available to the z-buffer.

    Let me know if that helps.

    Thanks,
    Paul.

    #39394

    Ex3n
    Member

    thanks i will give those ideas a try

    #39395

    Ex3n
    Member

    i wanted to make sure and get back on this. The code we are using was inherited by me and i found another place that was setting the depth buffer back to 16. this of course fixed the problem. I did want to note however that adjusting the near clip plane also fixed the problem. this is a bit more sketchy because you can get into situations where you will pop through your geometry but i wanted to note that if anyone is having issues with z-fighting changing that near clip plane will help.

Viewing 6 posts - 1 through 6 (of 6 total)
You must be logged in to reply to this topic.