Blackberry BB10 Deployment

This topic contains 6 replies, has 3 voices, and was last updated by  dgu 4 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #31351

    dgu
    Member

    Dear Team

    a long time ago i tested the blackberry part of the SDK and it was fine.
    I tried to deploy the sample called OGL alphatest and check out the bar files and it doesnt work. (the project file doesnt refere to the tools and shell lib anywhere as well ) .

    I did setup the global path variable for the workspace,

    I am able to deploy remotely GLES application using the BB10 sdk without any problems.

    That is very surprising , everything work fine on other plateform (maybe more populare for now…. 🙂 ).

    thanks alot if you can investigate ,

    regards
    david
    ps ALMOST ready to deploy on BB10 :))

    #37712

    Joe Davis
    Member

    Hi David,

    Can you clarify where the issue is, e.g. failed build, binary doesn’t run on device etc.
    Which version of the AlphaTest Example are you using? OGLES2?

    Also – which device are you targeting?

    Cheers,
    Joe

    #37713

    dgu
    Member

    Sorry Joe for my lack of precision ,
    Yes it is OGLES2 and it s happenning during the compilation.
    Taking yur project from scratch doesnt work by following the sdk documentation.

    #37714

    dgu
    Member

    Thanks to Scott, the file were invisible , i have to do a ctrl h to see them on my linux…..

    i am facing fatal error: error writing to -: Broken pipe during the compilation now using the latest update of the sdk

    Any idea ?

    i am sure it will work today 🙂

    thanks alot
    regards
    david

    #37715

    Scott
    Moderator

    i am facing fatal error: error writing to -: Broken pipe during the compilation

    Hi,

    The BlackBerry10 projects are setup by default to build on Windows. To build on Linux you’ll need to update a variable called FILEWRAP under Properties -> C/C++ Build -> Environment to point at the Linux version of our Filewrap utility. Alternatively, you can edit the org.eclipse.cdt.core.prefs under .settings by hand. Hopefully that is the only change needed. I haven’t personally tried compiling the BlackBerry10 SDK on anything but Windows.

    Cheers,

    Scott

    #37716

    dgu
    Member

    i understand , and i have this error on any single cpp files…argggggggggggggghhh !!!! wow
    ok i will correct it by hand then i was planning to do something else this afternoon 🙂

    thanks for you answer

    kind regards
    david

    #37717

    dgu
    Member

    One day Linux will be the main dev tools 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
You must be logged in to reply to this topic.