Bump mapping (nIdxTexBump)

This topic contains 2 replies, has 3 voices, and was last updated by  Scott 5 years, 8 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30831

    al.prater
    Member

    Hello,

    I hoping you guys can help me.

    Setup:

    I have a simple cube primitive with a lambert material applied (in Maya 2011).

    The lambert has both diffuse and bump map textures connected via external pngs.

    Issue:

    When I export to POD and load up the resulting scene (into iOS), I only find that the nIdxDiffuse is set.

    nIdxTexBump is always -1 and there is no entry in scene.pTexture for the bump texture.

    I’ve looked through the BumpMap and ParallaxBumpMap examples. Both load the textures from hardcoded chars. I’m attempting to implement the textures more like the other examples that loop through the pTextures (hence trying to get the bump texture in there).

    Any help/advice would be greatly appreciated.

    Thank you

    Al

    PS. Mac OSX 10.7 | Maya 2011 | PVR 2.10 | iOS 4+

    #35740

    JackAsser
    Member

    I had the same issue and the exporter only handles diffuse textures. I solved it by having a naming scheme, so when the diffuse texture was loaded i also checked for specuöar and bump and dynamically added those if they were found.

    #35741

    Scott
    Moderator
    al.prater wrote:
    Issue:

    When I export to POD and load up the resulting scene (into iOS), I only find that the nIdxDiffuse is set.

    nIdxTexBump is always -1 and there is no entry in scene.pTexture for the bump texture.

     

    Hi,

     
    Thanks for reporting this issue. I can confirm it is a bug with the exporter and it will be fixed in a future release.
     
    Cheers,
     
    Scott
Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.