Can’t compile android openGLES 2.0 example..

This topic contains 1 reply, has 2 voices, and was last updated by  Scott 7 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30175

    Hello Dear,

     

    I have just download openGLES 2.0 SDK for android platform.But I can’t able to compile/build any of the examples.I am using Eclipse(java) and Android 2.1 version SDK.When i try to compile any of the example from the openGLES 2.0 Sdk that time compiler show many errors.

     

    These are the errors which is occured during OGLES2IntroducingPOD compile:

     

    1.com.powervr.OGLES2IntroducingPOD.OGLES2IntroducingPOD does not extend android.app.Activity

    2. Error: No resource found that matches the given name (at ‘icon’ with value ‘@drawable/icon’).

    3.prefAppName cannot be resolved

    4.PVRShell cannot be resolved to a type

    5.R cannot be resolved

    6.The import com.powervr.PVRShell cannot be resolved

    7.The method initialise() of type OGLES2IntroducingPOD must override or implement a supertype method

     

     

    Basically I import the examples as a new android project and then select the android folder of the example( like OGLES2IntroducingPOD) directory.

     

    So how i can solve this error..or any other way to import this examples in Eclipse…

     

    Thanks

    Rassall
    #34015

    Scott
    Moderator
    rassall_jubair wrote:
    Hello Dear,

     

    I have just download openGLES 2.0 SDK for android platform.But I can’t able to compile/build any of the examples.I am using Eclipse(java) and Android 2.1 version SDK.When i try to compile any of the example from the openGLES 2.0 Sdk that time compiler show many errors.

     

    These are the errors which is occured during OGLES2IntroducingPOD compile:

     

    1.com.powervr.OGLES2IntroducingPOD.OGLES2IntroducingPOD does not extend android.app.Activity

    2. Error: No resource found that matches the given name (at ‘icon’ with value ‘@drawable/icon’).

    3.prefAppName cannot be resolved

    4.PVRShell cannot be resolved to a type

    5.R cannot be resolved

    6.The import com.powervr.PVRShell cannot be resolved

    7.The method initialise() of type OGLES2IntroducingPOD must override or implement a supertype method

     

     

    Basically I import the examples as a new android project and then select the android folder of the example( like OGLES2IntroducingPOD) directory.

     

    So how i can solve this error..or any other way to import this examples in Eclipse…

     

    Thanks

    Rassall

     

    Hi,

     

    I’m afraid I don’t have any experience in building our Android JNI SDK with eclipse but instead prefer to build from a Linux terminal as described in the SDK user guide. However, I’ll try to help the best I can.

     

    Looking at your errors my guess is that you’re missing PVRShellApp.jar and OGLES2IntroducingPOD/OGLES2/Build/Android/res/drawable/icon.png. These files as well as the required .so are created by building the makefile located in OGLES2IntroducingPOD/OGLES2/Build/Android. From a quick google of building the Android NDK apps with eclipse it appears that you still need to perform this stage as described in the user guide and then use eclipse to create the final .apk.

     

    Thanks,

     

    Scott

     
Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.