Can’t Display the Bone animation.

This topic contains 3 replies, has 2 voices, and was last updated by  rick 8 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29909

    rick
    Member

    I exported a pod file from Maya 8.5, PVRTShaman 1.6, which has bone animations. It runs well in PVRTShaman, all animations are right as it’s in Maya, but I can’t render it correctly in my project-_-, there’s just a static model rendered in my project, no moving. the frame count is right, something like SetFrame(x) doesn’t not work.

    I used the render code from sample/mouse, any suggestion? thanks very much!:)

    the mouse_float.pod could be rendered correctly in my project, but when I use the file mine, it has problem-_-

    thanks.

    #33360

    Scott
    Moderator

    Hi,

    The mouse example doesn’t use bone animation for animating its character so the render code will be incomplete for your needs. For an SDK example that uses bone animation please look at the  MatrixPalette and/or Skinning training courses.

     

    Thanks,

     

    Scott
    #33361

    rick
    Member

    Thanks a lot!:)

    Now I can display the my model in my App by the codes from Skinning. It looks much better. but there’re still something wrong, It seems ES1.1 in iPhone doesn’t support Bone weight well? there’s no effect on bone weight.

    and I’ve checked the sample in oolong, MatrixPalette, it’s also looked different(strange) from the training course in GLES SDK in windows.

    Does GES in iPhone support bone weight?

    in my testing, glCurrentPaletteMatrixOES() doesn’t make any effect.

    Thanks very much!

    #33362

    rick
    Member

    It seems relations to iPhone OS version, it runs strange in OS2.2.1, but runs very well in iPhone OS 3.0..-_-

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.