Can’t see textures on bada samples

This topic contains 3 replies, has 2 voices, and was last updated by  alvalea 7 years ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30305

    alvalea
    Member

    Hi,

    I’ve been trying the bada sdk, but I can’t see the textures in the demos. For example, in the Water demo, the skybox texture isn’t showed.

    The demos are working in the bada simulator and I can see all the content. But the textures doesn’t appear. The objects are drawed with a color instead of with an image.

    I’ve tried the bada sdk with a computer that has an intel integrated graphic chip. And also in a laptop with an ATI mobility radeon 5650 graphic card. But the result is the same. I can’t see the textures in none of them.

    Do you know what is the problem?

    Thanks

    #34391

    alvalea
    Member

    Actually I can run the powervr samples within the bada simulator from eclipse. For example, in the water demo, I can see the boat moving. But I can’t see the sail texture nor the wood texture of the boat. I see a uniform red color for the sail and a uniform brown color for the wood. I don’t know if this is a problem of compression of the textures in the pvr format…

    #34392

    Scott
    Moderator
    alvalea wrote:
    Actually I can run the powervr samples within the bada simulator from eclipse. For example, in the water demo, I can see the boat moving. But I can’t see the sail texture nor the wood texture of the boat. I see a uniform red color for the sail and a uniform brown color for the wood. I don’t know if this is a problem of compression of the textures in the pvr format…

     

    If I recall correctly the missing textures are all be compressed with PVRTC which isn’t correctly supported by the bada simulator, even though the extension string implies it is. A workaround for this problem is to recreate the textures using a format that isn’t PVRTC.
    #34393

    alvalea
    Member

    Ok, I just wanted to know if it was a problem of the simulator or if I was doing something wrong.

    Thanks a lot.

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.