Collada to pod conversion won’t work

This topic contains 15 replies, has 2 voices, and was last updated by  reiniervanvliet 5 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #30908

    Hi,

    I’ve been trying for days to convert a collada file (exported using opencollada from max) to pod.
    I don’t have the original max file (I am actively pursuing the client if I can get this) so it’s just the collada file.
    If I open the collada with preview (mac), it shows correct.
    If I open the file in sketchup. it shows correct
    If I open it in blender…it shows correct
    I’ve used 3 versions of blender (2.63, 2.49 and 2.59), the blender export to podplugin, the blender export to collada plugin, the collada2pod convert, sketchup export and any combination of the above, but I can not get the model to export correctly without the mesh looking completely scrambled when viewing it with shaman.  (Some of the submeshes look to have different orientations than the rest)
    Does anyone else have had these issues as wel? What is the thing what I should be doing next?
    thanks!
    Reinier
    #35949

    Scott
    Moderator

    Hi,

    If possible could you send your collada file, blender scene and a .pod file that shows the problem to devtech@imgtec.com. If you do happen to send us an email, could you please let us know on here so we know to expect one.

    Thanks,

    Scott

    Scott2012-07-03 10:05:51

    #35950

    It has been emailed!

    Thank you very much for your time
    Reinier
    #35951

    Scott
    Moderator
    reiniervanvliet wrote:
    It has been emailed!
     
    Hi,
     
    I’m afraid we didn’t get your email. Could you send it again please.
     
    Thanks,
     
    Scott
    #35952

    do you need to whitelist me first? (since I’ll be sending a zip file)

    my email: <removed to not get spam from automated spam crawlers>
    thanks
    Reinier

    reiniervanvliet2012-07-04 12:08:28

    #35953

    Scott
    Moderator

    Cheers, you’ve been added to the whitelist. Feel free to resend it, if you haven’t already.

    #35954

    Hi Scott,

    the file has been resent.
    The attachment is 4.1Mb though…I hope that is not a problem.
    Reinier
    #35955

    Scott
    Moderator

    It could possibly be the attachment as I’m afraid there has been no sign of your email our end (again). Are you able to host it somewhere or alternatively split the attachment up and send over several emails?

    #35956

    Hi,

    the model is downloadable at: <removed>
    can you confirm when you downloaded it? Then I’ll take t down again.
    thanks again!
    Reinier

    reiniervanvliet2012-07-05 09:06:29

    #35957

    Scott
    Moderator

    Cheers, we’ve downloaded it and will take a look as soon as we can.

    #35958

    great thanks!

    #35959

    Scott
    Moderator

    At least when exporting to POD from Blender something appears to be going wrong when decomposing the transformation matrix of some of the objects into pos, quaternion and scale. One way to work around this is to export your scene with the option “Export matrices” checked. When this is checked the transformation matrix is exported instead and no decomposing is done. 

     
    Hopefully, this will allow you to proceed while we investigate it further.
    #35960

    Hi Scott,

    could you specify the exact stept you are taking to get your solution?
     – If I try to use blender 2.63 and then export directly to pod(with export matrices checked) it’ll crash.
       Usually, I can’t use the blender/pod exporter directly since it doesn’t have the ‘invert transparency’ option which I need.
    – If I use the standalone collada2pod exporter on the model I sent you, and have export matrices checked, it still looks weird.
    thanks!
    Reinier
    #35961

    Scott
    Moderator

    I imported and exported the scene using Blender 2.63. To use the currently released Blender exporter with 2.63 you need to make a few minor changes to the exporter’s python script. They’re described in https://www.imgtec.com/forum/forum_posts.asp?TID=2200&title=pvrgeopod-with-blender-263.

     
     
    #35962

    Hi Scott,

    That did the trick!  The model looks correct now.
    The textures are missing though in shaman.
    I’ve edited the colada file to make texture references point to their .pvr versions, and removed the absolute path bits.
    then I converted it to the pod.
    when I load it into shaman, the model looks great, but I see no textures.
    Is this the way to normally convert a model along with it’s textures?
    thanks again,
    Reinier
Viewing 15 posts - 1 through 15 (of 16 total)
You must be logged in to reply to this topic.