Collada2POD doesn’t export colors?

This topic contains 3 replies, has 2 voices, and was last updated by  Scott 8 years, 7 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29758

    gfm
    Member

    Because I failed to get the 3dsmax9 exporter to properly export vertex colors, I thought I’d try going from max -> collada -> Collada2POD. However I can’t get any vertex colors to export at all w/ the Collada2POD exporter.

    Is there a trick to this? My DAE file is crazy-simple.

        <geometry id=”M_cube-mesh” name=”M_cube”>

          <mesh>

            <source id=”M_cube-mesh-positions”>

              <float_array id=”M_cube-mesh-positions-array” count=”24″>-25 -25 0 25 -25 0 -25 25 0 25 25 0 -25 -25 50 25 -25 50 -25 25 50 25 25 50</float_array>

              <technique_common>

                <accessor source=”#M_cube-mesh-positions-array” count=”8″ stride=”3″>

                  <param name=”X” type=”float”/>

                  <param name=”Y” type=”float”/>

                  <param name=”Z” type=”float”/>

                </accessor>

              </technique_common>

            </source>

            <source id=”M_cube-mesh-map-channel0″>

              <float_array id=”M_cube-mesh-map-channel0-array” count=”24″>0 0 1 0 1 0 0 1 0 1 0 0 0 0 1 1 0 0 0 1 0 1 0 0</float_array>

              <technique_common>

                <accessor source=”#M_cube-mesh-map-channel0-array” count=”8″ stride=”3″>

                  <param name=”R” type=”float”/>

                  <param name=”G” type=”float”/>

                  <param name=”B” type=”float”/>

                </accessor>

              </technique_common>

            </source>

            <source id=”M_cube-mesh-map-channel1″>

              <float_array id=”M_cube-mesh-map-channel1-array” count=”36″>0 0 0 1 0 0 0 1 0 1 1 0 0 0 0 1 0 0 0 1 0 1 1 0 0 0 0 1 0 0 0 1 0 1 1 0</float_array>

              <technique_common>

                <accessor source=”#M_cube-mesh-map-channel1-array” count=”12″ stride=”3″>

                  <param name=”S” type=”float”/>

                  <param name=”T” type=”float”/>

                  <param name=”P” type=”float”/>

                </accessor>

              </technique_common>

            </source>

            <vertices id=”M_cube-mesh-vertices”>

              <input semantic=”POSITION” source=”#M_cube-mesh-positions”/>

            </vertices>

            <triangles material=”Standard_1″ count=”12″>

              <input semantic=”VERTEX” source=”#M_cube-mesh-vertices” offset=”0″/>

              <input semantic=”COLOR” source=”#M_cube-mesh-map-channel0″ offset=”1″ set=”0″/>

              <input semantic=”TEXCOORD” source=”#M_cube-mesh-map-channel1″ offset=”2″ set=”1″/>

              <p>0 0 9 2 2 11 3 3 10 3 3 10 1 1 8 0 0 9 4 4 8 5 5 9 7 7 11 7 7 11 6 6 10 4 4 8 0 0 4 1 1 5 5 5 7 5 5 7 4 4 6 0 0 4 1 1 0 3 3 1 7 7 3 7 7 3 5 5 2 1 1 0 3 3 4 2 2 5 6 6 7 6 6 7 7 7 6 3 3 4 2 2 0 0 0 1 4 4 3 4 4 3 6 6 2 2 2 0</p>

            </triangles>

          </mesh>

        </geometry>

    #32916

    Scott
    Moderator

    Hi,

     

    Collada2POD should export the vertex colours. Are you using the most recent version? If you are could you send your collada file and your .pod file (so I can use the same export options) to devtech@imgtec.com.

     

    Thanks,

     

    Scott
    #32917

    gfm
    Member

    Files that repro this problem have been emailed.

    #32918

    Scott
    Moderator
    gfm wrote:
    Files that repro this problem have been emailed.
     

    Thanks. From your email I see you are using Collada2POD from the 2.02.0756 version of our SDK. Support for vertex colours wasn’t added until our 2.4 release. I’ve tested your collada file with the most recent version of Collada2POD and the vertex colours are being exported correctly.
Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.