Custom POD files ( PVRShaman )

This topic contains 2 replies, has 3 voices, and was last updated by  Arron 6 years, 3 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30271

    warmi
    Member

    I use a custom Lightwave exporter to create POD files.

    My custom POD files work just fine in my custom code ( which is internally using PVRTModelPOD) and display just fine with PVRShaman build 2.05.24.0737 (an older version) but they won’t show up at all in the latest PVRShaman.

    I am not sure what is causing that but I suspect it is something simple ( perhaps a value which is optional as far as PVRTModelPOD is concerned is required by PVRShaman or something like that)

    If you guys have some time, could you take a look at this very simplified pod file (literally just 1 triangle) which for some reason doesn’t show up when using the latest PVRShaman and see if I am missing something ?

    Even though it works my my code, I would love to get it working with the latest PVRShaman as I like and use that tool a lot.

    Here is the pod file:

    Minimal POD file

    Thankswarmi2010-09-02 12:09:59

    #34295

    Gordon
    Moderator

    Hi warmi,

    We’ve been able to reproduce the problem, but haven’t found a fix yet. This is now BRN31244 in our system and we’ll report back when we have a fix.

    #34296

    Arron
    Member

    Hi warmi.

    I’ve reviewed the problem and have found that the unpack matrix (SPODMesh::mUnpackMatrix) is not initialised within the POD file you supplied us with. Consequently the mesh vertices are being multiplied with an uninitialised matrix.

    If this matrix is set to identity, your POD file displays correctly.

Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.