eglCreateImageKHR fails with an XWindow pixmap?

This topic contains 0 replies, has 1 voice, and was last updated by  alextisserant 7 years ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #30392

    Hello,

    (post already posted in the PowerVR SDK forum but it may be more appropriate here; if not, please let me know)

    I’m trying to port Chromium OS on an Beagleboard. The hardware acceleration is provided by the PowerVR binaries. As explained in this report , I can setup the system, access a console, and successfully run the Raw demos provided in the PowerVR files.

    Unfortunately, I’m still facing the issue described in the bug, i.e. a failing call to eglCreateImageKHR returning an EGL_BAD_PARAMETER value. I tried a software workaround using glTexImage2D, which works, but is obviously very slow and makes the whole system almost unusable.

    I checked the test cases link provided by Prabindh Sundareson, and it seems that eglImageCreateKHR is tested; however, I’m not sure it’s supported with a pixmap from an X window as argument. Has anyone already successfully tested this use case? If yes, does anyone have any hint on what are the probable cases that would make it fail? If no, does anyone know any reasonable workaround?

    The call occurs on line 554 of opengles_visitor.cc (part of the ChromiumOS window manager package)

    This is our last real blocking bug to get a working release of ChromiumOS on Beagleboard, but we are stopped by this SGX problem. I think that the whole community will be very interested by this effort, thus any help would be greatly appreciated.

    Thanks in advance for any hint,

    Alexandre Tisserant – Always Innovating Team

Viewing 1 post (of 1 total)
You must be logged in to reply to this topic.