glBlendEquationOES 0 pointer from eglGetProcAddres

This topic contains 0 replies, has 1 voice, and was last updated by  gersen 7 years, 9 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #30064

    gersen
    Member

    Hi all,

    I’ve tried to access from the latest windows’ opengles 1.1 sdk to some gles extensions but for some eglGetProcAddress return a valid pointer but for others it return always NULL. I’ve tried using different Hardware Profiles from PVRVFRAME with no luck.

    More precisely I’m tring to retrieve those functions:
        glBlendEquationOES = (PFNGLBLENDEQUATIONOESPROC)eglGetProcAddress(“glBlendEquationOES”);
        glBlendFuncSeparateOES = (PFNGLBLENDFUNCSEPARATEOESPROC)eglGetProcAddress(“glBlendFuncSeparateOES”);
        glBlendEquationSeparateOES = (PFNGLBLENDEQUATIONSEPARATEOESPROC)eglGetProcAddress(“glBlendEquationSeparateOES”);

    and they’re always NULL. They are listed as supported from the extension list (ie GL_OES_blend_func_separate and GL_OES_blend_equation_separate are present) but I can’t get the address of the functions.

    Is there a bug on the emulator library?

Viewing 1 post (of 1 total)
You must be logged in to reply to this topic.