glDrawTex

This topic contains 2 replies, has 1 voice, and was last updated by  bobGL 7 years, 3 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30220

    bobGL
    Member

    Another driver bug found… mutli texturing with glDrawTex is simply not working properly… On iPhone (sim + device) no problem…

    And can one of the tech guys can PLEASE answer this post:

    https://www.imgtec.com/forum/forum_posts.asp?TID=893bobGL2010-07-21 02:18:27

    #34158

    bobGL
    Member

    In addition, using only 1 texture with glDrawTex and by specifying the depth using ex:

    glDrawTexfOES( 0.000000, 0.000000, 0.999000, 512.000000, 512.000000 );

    It is impossible to use the texture as a background and draw something in 3D on top of it… The Z value seems to be totally ignored…

    Following the OpenGLES specifications, glDrawTexOES should affect directly the color buffer and the depth buffer. It seems to me that this is not the way it have been implemented in PVR…

    #34159

    bobGL
    Member

    Ho! and also… once again following the GLES specifications glDrawTex shouldn’t rely on glClientActiveTexture in order to work… it should be on a texture ID basis and implemented through the texture parameters.

    Looks to me that the whole implementation of glDrawTex have been implemented as a hack, that basically ignore the specifications, and when combined with real GLES call inside a rendering pipeline shows that the implementation doesn’t behave the way it should be.bobGL2010-07-21 03:09:49

Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.