GPU fan speed ramps up when building within Visual Studio

Tagged: 

This topic contains 4 replies, has 2 voices, and was last updated by  trs79 4 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31339

    trs79
    Member

    Hello,

    if I run a pre-compiled binary in the SDK, for example

    C:ImaginationPowerVRGraphicsSDKSDK_3.1BinariesWindows_x86_32ExamplesBeginner2_IntroducingPVRShell

    I see the yellow triangle, and no gpu fan speed increase. However if I build the same example solution in Visual Studio 2010 and run it, my gpu fan speed gets dramatically louder and faster. Anyone have any ideas as to why this happens?

    #37650

    Joe Davis
    Member

    Hi,

    Are you using PVRVFrame to run both the pre-compiled binary & the one you’ve built yourself?

    I can’t see any reason why PVRVFrame our our SDK would cause this to happen. Does the fan only spin faster during the build, or also while IntroducingPVRShell has run for some time (e.g. 5-10 minutes)?

    Cheers,
    Joe

    #37651

    trs79
    Member

    Thanks for the response. Hmm, I guess I’m assuming PVRframe is used for both the precompiled binary and the one I built myself? But maybe that’s not the case. Is there any way to check?

    The fan starts spinning up immediately after running the program and stops as soon as I close it

    #37652

    Joe Davis
    Member

    There’s a free tool called Dependency Walker you can use to find out which DDL’s a Windows binary links to.

    If you can confirm that PVRVFrame is the cause & can provide us with a minimal reproduction for the issue, we can look into this for you.

    Thanks,
    Joe

    #37653

    trs79
    Member

    Ah looks like vsync was to blame. Are all the samples binaries built with vsync enabled by default? In my application if I call PVRShellSet(prefSwapInterval, 1); the fan speed doesn’t speed up. I guess it makes sense that without vsync the GPU is rendering as fast as possible which causes a fan speed increase. I thought vsync was disabled by default though

Viewing 5 posts - 1 through 5 (of 5 total)
You must be logged in to reply to this topic.