How to disable anti aliasing on the PC emulator

This topic contains 3 replies, has 3 voices, and was last updated by  chris 3 years, 6 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #31729

    tobyc
    Member

    I’m not sure why, but later versions of the PC emulator anti alias full screen by default. I have tried setting egl SAMPLE_BUFFERS to zero etc (this should be the default anyway), but I still get anti aliasing on poly edges and line drawing. Earlier versions of the PC emulator such as the one that came with SDK 3.0r2 doesn’t anti alias.

    Is there a way to turn this off on version 3.3 that I’m missing?

    #38790

    dgu
    Member

    Hello

    did you try :to set the shell with prefAASamples settings?

    regards
    david

    #38791

    tobyc
    Member

    I’m not using the PVR shell (as far as I know).
    I’m compiling it against the libEGL.lib and libGLESv2.lib that come with the SDK.

    #38792

    chris
    Moderator

    Hi Tobyc

    A quirk of EGL is that you can only specify the minimum number of multisample buffers, so specifying zero for EGL_SAMPLE_BUFFERS means you may still get an antialiased framebuffer config.

    If you really need AA to be disabled then you could iterate through the returned configs and use eglGetConfigAttrib to find one with no multisample buffer.

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.