How to export my objects correctly from Blender to Pod file?

This topic contains 6 replies, has 2 voices, and was last updated by  dgu 4 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #31319

    comatch
    Member

    Hi all.
    I started developing 3D iOS App few days ago. I tried building and running “Skinning example” ( SDK_3.1 -> Examples -> Intermediate -> Skinning -> OGLES -> Build -> iOS -> .xcode file ) and this ran well. And then, I tried to replace man.pod with my .pod file exported with PVRGeoPOD from my 3D objects generated Blender2.65a(OSX) . However, exported .pod file doesn’t contain any camera objects. When I opened this using PVRShaman, there is gray object in dark background. Why??

    Please tell me how to export my objects correctly from Blender and make it visible with PVRShaman.

    #37547

    dgu
    Member

    hello

    i cant see using your screenshot what material you did apply (pvr file).

    david

    #37548

    comatch
    Member

    Hi Dgu. Thank you for your comments.
    I applied pvr file which is converted from .png file with PVRTexTool (GUI).

    #37549

    dgu
    Member

    hello

    I can t see the material called “Material” under the node Armature , i was wondering why your plane is under your armature .

    it should be a different object node no ??.

    depending your texture that you use , how did you calculate your UV ? if you are using a render to texture principle you should set the Flipping checkbox to true;

    regards
    david

    #37550

    comatch
    Member

    Hi Dgu, tahnk you for your comments.

    In Blender, I think, the armature should be parent of meshes for its bone animation. Am i wrong about this?? :-/

    I found some solutions of my problems.
    1) In Blender, my camera should be “Perspective” (not “Orthographic”).
    2) In PVRGeoPod Options, “Data type” of the export mapping channels should be “float”.
    3) as Dgu says, I should set the Flipping checkbox to true.

    Then, I got good results. I could see my textured object with PVRShaman. Its bone animation works well too.

    However, I still have the problem. In “Skinning Example”( SDK_3.1 -> Examples -> Intermediate -> Skinning -> OGLES -> Build -> iOS -> .xcode file ) , when I switched the default pod file to my pod file, I can see only cyan background, there is no 3D objects. I dont know why.
    Please advise me.

    thanks.

    #37551

    comatch
    Member

    Hi all.
    I found the cause of my last problem.
    In OGLESSkinning.cpp, I changed the value of CameraNear.

    const float g_fCameraNear = 1.0f;

    Then, I got good result.

    thank you!

    #37552

    dgu
    Member

    that is superbe a good result i am happy for you

Viewing 7 posts - 1 through 7 (of 7 total)
You must be logged in to reply to this topic.