How To Turn Off Flipping with PVRTexToolCL?

This topic contains 7 replies, has 2 voices, and was last updated by  Joe Davis 4 years, 6 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #31293

    Jahiro
    Member

    If I turn off flipping by unchecking the ‘Vertical Flip’ tick box in the GUI, my PVR does not have flipping, but when using the latest PVRTexToolCL, I am unable to disable flipping.

    Previously, this was achieved with “-yflip0”. Can someone please help me understand how to achieve this with the new CL Tool? I’ve tried with “-flip y” and without “-flip y” but in both cases, flipping occurs.

    #37366

    Jahiro
    Member

    No one can help with this? I’ll have to go back to using the old version of PVRTexToolCL – shame to see the latest version with bugs like this, as I was really hoping to use the new features.

    #37367

    Joe Davis
    Member

    Hi,

    Can you share the command-line arguments you’re using with us?

    PVRTexToolCL in our current release shouldn’t flip by default (if it does, it’s a bug). However, the legacy interface will flip by default.

    Thanks,
    Joe

    #37368

    Jahiro
    Member

    Hi Joe,

    It definitely seems like the CL tool is always flipping.

    I’ve reverted to the old CL, so don’t have the command line arguments, but I can tell you how to recreate the issue – follow the instructions here on preparing a PVR file for use with Adobe’s PVR2ATF tool (which only accepts non-flipped PVRs in OpenGL ES 2.0 PVRTC 4BPP (OGL_PVRTC4) format )- you will see that it’s impossible to prepare a suitable PVR with the latest CL tool, due to the PVR being flipped, regardless as to the parameters passed.

    However, it’s easy to prepare an acceptable PVR using the latest GUI or the old CL, so it definitely seems like a bug with the latest CL.

    #37369

    Joe Davis
    Member

    Hi,

    Thanks for the details. I’ll discuss the issue with the lead PVRTexTool engineer.

    Joe

    #37370

    Joe Davis
    Member

    Hi Jahiro,

    Are you using the “-legacypvr” flag when generating your file? As discussed in this FAQ article, we’ve updated our container format. It’s possible that the Adobe tool only supports our legacy format (PVR v2).

    Thanks,
    Joe

    #37371

    Jahiro
    Member

    I got it working! I’m a PVR n00b, so I thought that Adobe’s “OpenGL ES 2.0 PVRTC 4BPP” requirement would translate to the “PVRTC2_4” format, but this was giving misleading pixel and flipping errors in Adobe’s PVR2ATF tool.

    Turns out the correct format is “PVRTC1_4” – no need for the legacy flag – these arguments work fine with Adobe’s PVR2ATF:

    PVRTexToolCL -f PVRTC1_4 -i spritesheet.png -o spritesheet.pvr

    #37372

    Joe Davis
    Member

    Ah. Easy mistake 🙂

    Glad to hear you’ve got it working now.

    Thanks,
    Joe

Viewing 8 posts - 1 through 8 (of 8 total)
You must be logged in to reply to this topic.