how to use MVED in Marvell ‘s Pxa310

This topic contains 2 replies, has 2 voices, and was last updated by  janemxq 4 years, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #31197

    janemxq
    Member

    i develop a camera video Recorder app in wince 6 ,CPU is PXA310,RAM is 80M,i want to use MVED (multi-standard video Encode Decode) function,
    but error ( ERROR: PVRRC_HARDWARE_NOT_AVAILABLE ),how to solve,then look this code:

    PVR_INSTANCE uInstance;
    PVR_API_TYPE n1=PVR_VEA;
    PVR_VIDEOSTANDARD n2=PVR_MPEG4_ASP;
    PVRRC res;

    typedef PVRRC (* ProjectWizDLL)( /*out */ PVR_INSTANCE *phInstance,
    /*in */ PVR_API_TYPE eAPIType,
    /*in */ PVR_VIDEOSTANDARD eVideoStandard);
    //typedef BOOL (* ProjectWizDLL)(TCHAR * pProjectPath);
    HINSTANCE hmod;
    hmod=LoadLibrary(_T("pvr_mved1.dll"));
    ProjectWizDLL lpproc;
    lpproc = (ProjectWizDLL)GetProcAddress (hmod,_T("PVRInitialise"));
    res=(*lpproc)(&uInstance,n1,n2);

    #36908

    Joe Davis
    Member

    Hi Janemxq,

    This seems to be an issue with a PowerVR Video core, rather than a Graphics core. This forum is for graphics support. I can forward this report onto a member of our Video team, but I think you should also discuss this with your platform provider in case this is a platform specific problem.

    Regards,
    Joe

    #36909

    janemxq
    Member

    thanks,but Marvell’s support is poor, :-<

Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.