How to use overlay transparent layer by Using DRM with GLES on PowerVR SGX544MP2

This topic contains 3 replies, has 2 voices, and was last updated by  Joe Davis 2 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #31939

    ginjoe
    Member

    Hi.

    I am trying to draw using multiple layers using GLES and DRM.
    I am able to simply drawn with GLES for multiple layers.
    However, transparent color of the upper layers is not reflected.
    A result of the investigation, it was found to be that allows the setting of alpha values for the layer in ‘drmModeObjectSetProperty’.
    But I don’t know is should I pass what the argument for setting the alpha value (Object Type, Object ID, Property ID) .
    Could you advice me?

    Thank you.
    ginjoe

    #39356

    Joe Davis
    Member

    Hi ginjoe,

    I’m not familiar with the DRM framework you are referring to.

    I would recommend using our PVRTrace OpenGL ES capture and analysis tool to verify that you are correctly setting the blend mode & associated functions. If your application isn’t setting blend modes correctly, then there may be a bug in the logic of your application or the framework you are using.

    Regards,
    Joe

    #39357

    ginjoe
    Member

    Hi Joe.

    Thank you for your answer.

    That tool is great !!
    But My question is very elementary question.
    I have not been able to yet use even API for setting…

    However I was worth having asked you a question just to have been able to know this tool !!
    thank you.

    ginjoe

    #39358

    Joe Davis
    Member

    Hi ginjoe,

    If you’re new to OpenGL ES and want to know more about setting blend modes, I would recommend referring to the source code of our SDK’s AlphaBlend Example.
    https://github.com/powervr-graphics/Native_SDK/blob/3.4/Examples/Intermediate/AlphaBlend/OGLES2/OGLES2AlphaBlend.cpp

    Let us know if there is anything else we can help you with.

    Joe

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.