I cannot run some demos

This topic contains 5 replies, has 3 voices, and was last updated by  Xmas 9 years, 4 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #29529

    cxzeng
    Member

    Hi, everyone, some demos shows cannot load the .pod file in SDK1.1. Did you meet the same problem? How to handle it?

    Thanks.

    #32123

    Gordon
    Moderator

    I need to know a bit more before I can help you, I think. Which platform are you running the SDK demos on? Are these the binary versions we supply or have you built them yourself from source? Which particular demos?

    G

    #32124

    cxzeng
    Member

    Thanks, sorry for the late response. I use Windows XP and Visual C++  2005 to compile the demo codes.

    I can run some demos, such as Vase, Mouse. But regarding to ChameleonMan, OptimizedMesh, PhantomMask and ShadowTechniques, I cannot run since it says, “Failed to load POD scene” or “Failed to load Sphere_*.pod”, do you know why is that?

    Thanks a lot!

    #32125

    Xmas
    Member

    These demos need to load .POD files, which have to be in the current working directory.

    If you want to run them in Visual Studio, go to Project->Properties, select Debugging on the left side and set Working Directory to “….”. The .POD files are generally two levels up from the project file, e.g. if the project file is in DemosChameleonManOGLESBuildWindowsPC, the .POD files are in DemosChameleonManOGLES.

    #32126

    cxzeng
    Member

    Thanks, I select the working directory, but it shows the same error information, that “failed to load POD scene”!

    Is there any other cause? Thank you!

    #32127

    Xmas
    Member

    Could you try to copy the .POD files to where the executable is, and run it outside of Visual C++?

Viewing 6 posts - 1 through 6 (of 6 total)
You must be logged in to reply to this topic.