installed powerVR SDK and need help opening example Xcode projects.

This topic contains 4 replies, has 2 voices, and was last updated by  blamejane 4 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31073

    blamejane
    Member

    I’m familiar with powervr sdk, as I’ve created an app using the previous sdk. I’ve just upgraded to the new 3.0 sdk after installing the lightweight installer and downloading the entire package (i accepted the defaults for the download choices), everything downloaded complete and the installation finished just fine.

    I’m now trying to load any of the demo (example) Xcode projects, but get an error like this:

    Project /Applications/Imagination/PowerVR/GraphicsSDK/SDK_3.0/Examples/Beginner/07_IntroducingPOD/OGLES2/Build/iOS/OGLES2IntroducingPOD.xcode cannot be opened because it is missing its project.pbxproj file.

    I’ve tried accessing the documentation, in case there’s a process for building these that I need to follow, however I get an error from safari that I don’t have permission to open the example help html pages.

    I really don’t understand what could be wrong, any help would be greatly appreciated.

    #36394

    Arron
    Member

    Hi Blamejane.
    There’s an issue with the installer at the moment which sets incorrect permissions for the SDK folder on OS X.

    You can solve this problem by doing the following:
    1. Open a terminal window
    2. cd /Applications/Imagination/PowerVR/GraphicsSDK/
    3. Make note of your unix username. This is displayed just before the $ character in the terminal.
    4. sudo chown -R YOUR_USERNAME SDK_3.0/
    4.1 Enter your account password

    This should fix the problem. We are changing the install path for the SDK in future releases which will resolve this issue.

    #36395

    blamejane
    Member

    Thanks. So…

    Was that posted somewhere that I missed?

    #36396

    Arron
    Member

    Possibly – we have just moved to this new forum system so previous posts regarding this issue may not be tagged correctly and/or searchable.

    Please remember to mark the answer as correct (I assume this worked for you) so it may help others :). We will probably create a temporary FAQ item for this issue until the problem is resolved also, to make things easier.

    #36397

    blamejane
    Member

    Thanks for the FAST help!

Viewing 5 posts - 1 through 5 (of 5 total)
You must be logged in to reply to this topic.