libGL error: unable to load driver:

This topic contains 11 replies, has 3 voices, and was last updated by  Manuel 3 hours, 11 minutes ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #60218

    Manuel
    Member

    I am using and open source platform which has a PowerVR SGX544MP1 as GPU. This device works with Linux and I am trying to develop applications with OpenGL even though when I run this command “glxinfo”in the console , I got this error:

    libGL error: unable to load driver: pvr_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: pvr

    Could somebody help to solve this problem ? or How can I update the latest version of GPU driver ?

    #60229

    Hi Manuel,

    It is strange that glxinfo is having trouble. It might mean that you do not have OpenGL ES drivers on your system. What do you get if you run this: cat /proc/pvr/version
    If you do not have drivers you will need to request them from your platform supplier.

    Best regards.

    Carlos.

    #60238

    Manuel
    Member

    Hi Carlos Sarria

    First of all thank you for your reply .

    I enter the command : “cat /proc/pvr/version” and I got this result:

    Version SGX_DDK_Linux_XOrg sgxddk MAIN@3841212 (release) sunxi_linux
    System Version String: SGX revision = 1.1.5

    Could you help What does it mean ? .

    Besides do you know where is the powervr.ini?.

    I am looking forward from you.

    Best regards,
    Manuel

    #60239

    Hi Manuel,

    So yes, you have OpenGL ES drivers in your system. That does not specify a branch but just “MAIN” is not very good because this is an engineering drop not intended for production.

    Anyway, you should be able to start the pvr module like this: /etc/init.d/rc/pvr start

    The powervr.ini should be located in /etc/powervr.ini or Application directory or Home directory. This is a file which allows you to specify hints to the driver to modify its behavior. This can be done at a global or application level.

    Regards.

    Carlos.

    #60240

    Manuel
    Member

    HI Carlos

    I couldn’t find the path that you suggest me : “/etc/init.d/rc/pvrstar” to enable the pvr module. I am just able to access to “/etc/init.d/rc” . In order words there is not file after “rc” called pvrstart . Therefore, Do I have write something in the “rc” file to enable the module. ?. Regarding with the powevr.ini file, I could not find it on my system

    Please help me , how can I solve those problems because I have been working more than one week to enable the powervr to write some basic examples in Qt with openGL but I haven’t gotten any successful result.

    I am looking forward from you
    Best regards,
    Manuel

    #60241

    Hi Manuel,

    “start” is the command. You need to put an space: /etc/init.d/rc/pvr star.
    Once you have started the module you should be able to run OpenGL ES applications. You should run any simple OGLES application to test that everything is working fine before attempting to run QT.

    Regards.

    Carlos.

    #60242

    Shaun
    Member

    Hi Manuel,

    If that does not work try: /etc/init.d/rc.pvr start
    Or:

    pvrsrvctl –start
    • This reply was modified 15 hours, 21 minutes ago by  Shaun.
    • This reply was modified 15 hours, 21 minutes ago by  Shaun.
    • This reply was modified 15 hours, 20 minutes ago by  Shaun.
    #60246

    Manuel
    Member

    HI carlos

    Thank you so much, but I don’t understand when you said that I should be able to enable the module like this : /etc/init.d/rc/pvr start. Do I have to run “/etc/init.d/rc/pvr start” in the terminal ? or Do I have to write this text “pvr start” in any part of the “rc ” file which path is /etc/init.d/rc .

    I am so sorry if my questions are so basic because I dont have so much experience on Linux, or Could you sned me some information how to enable and run a OGLES APPLICATION to test.

    I really appreciate that,

    Thank so much

    Best regards,
    Manuel

    #60247

    Shaun
    Member

    Execute the command “/etc/init.d/rc.pvr start” at the terminal, you may need to be root user (admin).

    • This reply was modified 15 hours, 12 minutes ago by  Shaun.
    #60249

    Manuel
    Member

    Hi Shaun

    Thank you for joining for this request;

    I execute the commands on the terminal that you suggest me and I got this result:
    Command : sudo su
    ———————————
    Command : /etc/init.d/rc/pvr start
    Answer: bash: /etc/init.d/rc/pvr: Not a directory
    —————————————
    Command : pvrsrvctl –start
    Answer: pvrsrvctl: must specify mode of operation
    ———————————
    Command : /etc/init.d/rc.pvr start
    Answer : No such file or directory

    Could you help with any other idea how can I enable the module? . Besides , The powervr.ini is not in my system. Maybe, do you know? why is it happening?

    Thank you so much
    I am looking forward from you
    Best regards,
    Manuel

    #60250

    Shaun
    Member

    I think the issue you are having with pvrsrvctl is when you specify the command line arguments you are using one “-“ and not two i.e. “-” “-” start – if i put two hyphens together the forum formats it as a single dash. Hopefully that makes sense?

    Also this command: “/etc/init.d/rc/pvr start” should be -> “/etc/init.d/rc.pvr start”

    • This reply was modified 13 hours, 58 minutes ago by  Shaun.
    • This reply was modified 13 hours, 58 minutes ago by  Shaun.
    #60253

    Manuel
    Member

    Hi Shaun

    I run this commands :

    Command : pvrsrvctl – -start ( it was typed with two “-“”-“start )
    Asnwer : Failed to load /lib/modules/3.4.39-BPI-M3-Kernel/extra/dbgdrv.ko: No such file or directory
    ——————————————–
    Command : /etc/init.d/rc.pvr start
    Answer : bash: /etc/init.d/rc.pvr: No such file or directory

    Do you know what is the problem and how to solve it?
    Thank you
    Best regards,
    Manuel

    • This reply was modified 3 hours, 3 minutes ago by  Manuel.
    • This reply was modified 3 hours, 2 minutes ago by  Manuel.
Viewing 12 posts - 1 through 12 (of 12 total)
You must be logged in to reply to this topic.