Lost pivot when exporting POD

Tagged: ,

This topic contains 5 replies, has 2 voices, and was last updated by  dgu 3 years, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #31687

    stalexwang
    Member

    I exported a scene as POD from blender, then open it in Shaman. All objects are placed at (0, 0, 0).
    Does GeoPOD keep the pivot of objects?

    #38674

    dgu
    Member

    Hello

    when you exported your model, did you select world coordinate even if it is not an animation ?
    i believe that your model are in model space coordinate that is why.
    its true that the wizard should be improved, it s a bit confusing.

    Kind regards
    david

    #38675

    stalexwang
    Member

    Thanks for the quick answer!

    I think my description was a bit confusing.
    It’s not that all objects were placed at (0, 0, 0), but their pivot points were at (0, 0, 0). So, it’s rotating around (0, 0, 0) instead of their own pivot.

    #38676

    dgu
    Member

    I don’t know your authoring tools but by my side i have to make sure that my pivot are centered correctly before exporting in world coordinate (depending the case) using adjust pivot tabs and even if you export in model space you object will be not centered necessarily at 0,0,0.Are you sure you pivot is located where it should be ?

    #38677

    stalexwang
    Member

    I’m using Cocos3D.
    The pod was exported with 3DS Max 2014.

    I also tried Blender. And the pivot was correct.

    #38678

    dgu
    Member

    if the model was exported in world coordinate that is normal behavior you need to translate an rotate around the center position

Viewing 6 posts - 1 through 6 (of 6 total)
You must be logged in to reply to this topic.