Multisampling

This topic contains 2 replies, has 2 voices, and was last updated by  nicobi 7 years, 7 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #30032

    nicobi
    Member

    Hello,

    I’m currently using PowerVR emulation software for OpenGL ES 2.0. While observing lot’s of aliasing in the rendering window, I tried to activate multisampling using following configuration for EGL :
    EGL_LEVEL, 0,
    EGL_NATIVE_RENDERABLE, 0,
    EGL_BUFFER_SIZE, 0,
    EGL_DEPTH_SIZE, 16,
    EGL_SURFACE_TYPE, EGL_WINDOW_BIT,
    EGL_RENDERABLE_TYPE, EGL_OPENGL_ES2_BIT ,
    EGL_SAMPLE_BUFFERS, 1,
    EGL_SAMPLES,2, /* or even 4 */
    EGL_NONE

    But i was’nt able to observe any change in the rendering window. Am I missing something ? Is antialiasing supported in the emulation software ?

    #33677

    jacekc
    Member

    Hi,

    I’m sorry for a delay in answering. Antialiasing is supported in Pc emulation.

    Do you have multisampling working in normal desktop openGL ? What is configuration (operating system, GPU etc., what SDK version are you using) ? I would like you to run some training course from our SDK eg. IntroducingPOD but from commandline. There should be an argument passed to commandline:  -FSAAMode=2     , and tell me if this triggers FSAA for you?  

    #33678

    nicobi
    Member

    Thanks for your answer. The problem was that the textures were not filtered using GL_LINEAR, producing nasty effects on the screen. 

Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.