OGLES-1.1_WINDOWS_PCEMULATION_2.05.25.0804 problem

This topic contains 3 replies, has 2 voices, and was last updated by  jacekc 8 years, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29903

    warmi
    Member

    It looks like with the latest SDK GL_OES_framebuffer_object and GL_OES_mapbuffer extensions are no longer working.

    I had no problem accessing GL_OES_framebuffer_object under OGLES-1.1_WINDOWS_PCEMULATION_2.04.24.0811 but it appears to be missing with the latest SDK ( also confirmed by looking at the new console log )

    Is it a bug or perhaps I need to enable something ?

    #33350

    jacekc
    Member

    Hi,

    If you are running 2.5 SDK then it is likely that you can see PVRVFrame control window (small GUI), where you can toggle visiability of the Log. if this is so then please make log enable

    and at beginning of it you can see (second line) , GL_RENDER string being displayed. The hardware profile should be mentioned there. eg.

    RENDERER: PoverVR PVRVFrame 5.1 [hardware profile] ….

    where hardware profile is : SGX530 , MBXLite, MBXLite with VGPLite etc.

    OES_framebuffer is available for SGX530, SGX535 and generic profiles only . By default MBX with VGP is being set that do not support OES_framebuffer extension as well.

    If that is a case then change the profile in General Options (menu command: Options->General) to one of the mentioned profiels that support that extension.

    The list of supported extensions is also displayed in Log in forth line: EXTENSIONS:….

    You can find more detailed description of how PVRVFrame Control Window in PVRVFrame Manual.

    Tell us if this helped

    jacekc2009-08-26 12:07:45

    #33351

    warmi
    Member

    Thanks … it worked fine.

    Quick question … reading thru the docs , it seems that the OES_mapbuffer extension doesn’t allow to read from the buffer and it can only be used for updates … is that correct ?

    #33352

    jacekc
    Member

    Yes this is correct that OES_mapbuffer dosen’t allow reading

    jacekc2009-08-26 15:19:48

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.