PowerVR OpenGl ES 2.0 winodws PC emulation example Run-Time Check Failure #0

This topic contains 9 replies, has 3 voices, and was last updated by  Joe Davis 2 years, 2 months ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #49489

    Anusha
    Member

    I am new to PowerVR OpenGl ES platform. I have downloaded PowerVR SDK on windows am trying to run the examples given in the SDK and implemented few sample programs to make it work in visual studio 2013.

    I am getting an exception as Run-Time Check Failure #0 – The value of ESP was not properly saved across a function call. This is usually a result of calling a function declared with one calling convention with a function pointer declared with a different calling convention at command line eglDisplay = eglGetDisplay(deviceContext); in the examples. Any program of OpenGL ES is resulting in the same exception and am getting a blank page.

    Is there any solution to this? I am implementing examples provided in SDK in visual studio 2013, Windows 8.1 PC, computer name MSC17709, 64 bit OS, Intel core i7. Please advice me how to run OpenGL ES 2.0 program in windows PC.

    Thanks

    #49502

    PaulL
    Admin

    What GPU do you have installed, and what graphics driver version?

    #49509

    Anusha
    Member

    graphics driver version is NVIDIA GeForce GTX 750 Ti and Intel(R) HD Graphics 4600. Thanks

    #49559

    Joe Davis
    Member

    Hi Anusha,

    Have you check that your graphics drivers are up to date?

    Did this problem occur with an unmodified Example from our SDK? If you can provide reproduction steps for the issue, we can investigate.

    #49639

    Anusha
    Member

    Hello Joe,

    Yes My graphics drivers are up to date.
    Yes, the problem occurs from unmodified example in SDK.
    Run-Time Check Failure #0 – The value of ESP was not properly saved across a function call. This is usually a result of calling a function declared with one calling convention with a function pointer declared with a different calling convention. exception at line such as m_EGLDisplay = eglGetDisplay(m_NDT);

    can you please suggest me how to proceed,

    thanks

    #49640

    Joe Davis
    Member

    Yes, the problem occurs from unmodified example in SDK.

    Which example did you use to reproduce the issue? Are there any SDK examples that run without encountering this issue? Once we have reproduction steps, we will investigate.

    #49676

    Anusha
    Member

    Yes,only few examples are working in intermediate and advanced such as Five Spheres, Lighting, skybox etc.

    #49734

    Joe Davis
    Member

    Can you list some examples that are not working? We’ve never seen this problem before. The more specific you can be of the reproduction steps, the easier it will be for us to investigate.

    #49776

    Anusha
    Member

    hello, nothing in the beginner examples are working and
    In advanced – OGLES PolyBump
    In advanced – OGLES Skybox
    In advanced – OGLES EvilSkull
    In Intermediate – OGLES FiveSpheres
    In Intermediate – OGLES Antialiased Lines
    In Intermediate – OGLES lighting
    In Intermediate – OGLES MatrixPalltte
    In Intermediate – OGLES OptimizedMesh
    In Intermediate – OGLES ShadowTechniques
    In Intermediate – OGLES Trilinear
    In Intermediate – OGLES UserClipPlanes

    except these no other examples are working in intermediate and advanced.

    The same error is occurring as in the picture when compiled at egldisplay etc in PVRShellAPI.cpp.

    Attachments:
    You must be logged in to view attached files.
    #49779

    Joe Davis
    Member

    Hi Anusha,

    We haven’t been able to reproduce the issue with the OGLES2OcclusionQueries demo. Can you check which OpenGL ES and EGL libraries you are linking to? We suspect the error may be caused by your application linking against some of PVRVFrames libraries and some from another driver (e.g. a native NVidia OpenGL ES driver).

    If you can share your Visual Studio output with us, it should help us determine if there are any issues with your dynamic linking.

Viewing 10 posts - 1 through 10 (of 10 total)
You must be logged in to reply to this topic.