Problem parsing/rendering POD file

This topic contains 1 reply, has 2 voices, and was last updated by  Gordon 6 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30501

    ajitvsudn
    Member

    Hello all,

     

    I am a n00b to using the powervr sdk. So please bear with me if my problem is quite trivial.

     

    I am trying build a 3d app on the android. To start off, I just want to render a simple 3d model on the screen. For this, I dug through the IntroducingPOD trainingcourse sources. I managed to compile it and get it running on the device.

     

    Now, if i have a simple pod file, exported from 3dsmax, say a lamp. It has no texures/shading…just a model.  Basically, i just want to be able to render just the geometry of ths model on the device. I am trying to modify the .cpp file of IntroducingPOD, but i am not succeeding. I am quite lost amidst all the various processing techniques that are presented in that.

     

    If someone can point me in the right direction, i would really appreciate it.

     

    Thanks

    -A
    #34855

    Gordon
    Moderator

    While we’ve made some attempt to make this Training Course easier to alter for other POD files, it is still primarily written to work with the POD that’s provided. I assume that the unaltered training course ran correctly?

    If you open your model in PVRShaman does it display correctly?

    There are various differences that could be present in the POD files that could be affecting this e.g. The camera in IntroducingPOD is set to look at a fixed position with a fixed angle of view. The position of your model may mean that it isn’t visible. Are you using interleaved data (this is set in PVRGeoPOD/Collada2POD and I believe our POD uses this)?

    You can load the settings from a POD file at export – one approach might be to load the settings from our POD and compare that to what you’ve been exporting.

    Please post again if you’re still having trouble.

Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.