Problem with Chameleon Man example on iPad2

This topic contains 3 replies, has 2 voices, and was last updated by  gavin1969 6 years, 8 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30502

    gavin1969
    Member

    Hi

    I’m new to the PVR SDK, so apologies if the solution to my issue is obvious.

    I’ve been taking a look at the example applications, and have come across a problem with the Chameleon Man demo which only happens on an iPad2.

    Please see the attached image.

    I’ve built and run the app with no problems on iPad1, iPhone 4.

    Any suggestions why there should be such a significant difference between the platforms or what the fix might be?

    Cheers,

    Gavin

    #34856

    gavin1969
    Member

    Just to note, also ran fine on 3GS and simulator, so I’m only seeing this issue on iPad2.

    Would be great if anyone out there with an iPad2 could build the sample (as it comes) to exclude the possibility I have a (2nd) faulty iPad2!!

    I tried changing the bone matrix arrays from highp to medium, the bug remained by distribution of polygons changed. Couldnt determine if it was a shader compiler bug….gavin19692011-04-13 15:14:27

    #34857

    Gordon
    Moderator

    I’ve reproduced this on our iPad 2 – it’s now issue BRN33259 in our system and we’ll post back when we have more information.

    Interestingly, the Skinning training course in the same SDK seems to work fine (you’ll notice a similarity in the main character).

    #34858

    gavin1969
    Member

    That’s a relief! Sort of..! 🙂

    I’ve not taken a look at the training stuff yet, just went straight to the examples to see which techniques worked well on the devices. Been putting off the move from 2d to 3d on mobile platforms…

    I’ll give that other sample a look.

    Thanks!

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.