Problem with OpenCL environment for Powervr sgx540 in Ci20

This topic contains 0 replies, has 1 voice, and was last updated by  silvermaple 6 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #55261

    Hi, Creator Team,

    I got my Ci20 Board last month and I intended to run some OpenCL programs using the sgx540 gpu in Ci20. I flash a debian 8 system into the board. During the setup time I had some trouble.

    When I run the sample program to perform vector addition. It reports error code -1001 in the line:
    clGetPlatformIDs(1, platforms, NULL);

    After that, I installed clinfo only to get the message:
    “icd loader reports no usable platforms” .

    It seems that I haven’t set up my OpenCL environment properly. Could anyone give me some instructions on how to run OpenCL with Ci20 gpu?

    I tried to download the powervr sdk file from official website, but the format of file is not match with mips, so I can not run the sdk file. Actually it happened when I tried to install sdk in cubieboard 4 too. So please leave your reply if you have any advices on:

    1. how to setup environment for OpenCL on linux using the powervr sgx540 gpu.
    2. how to setup environment for OpenCL on Android using the powervr sgx540 gpu.
    3. how to install powervr sdk in Ci20 (debian system)

    Thanks very much!
    (if you have any idea for opencl in cubieboard4 (powervr g6230), do give me some tips too!)

    Regards,
    SilverMaple

    2 users thanked author for this post.
Viewing 1 post (of 1 total)
The forum ‘Creator Platforms’ is closed to new topics and replies.