Problem with transition from POD to Zapworks Studio

This topic contains 12 replies, has 2 voices, and was last updated by  CarlosSarria 8 months, 1 week ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #55382

    edwind
    Member

    Hi,
    New to 3D models, I am on a very steep learning curve. However, I have made a model in Blender, exported it through the PVR plugin as a POD but when it opens in PVR Shaman, there are no materials applied. The report says ‘compiler not triggered’.
    Any help with this would be greatly appreciated.
    Edwind
    I can make the blend file or POD available for download if that would help.

    #55384

    Hi,

    To be able to export materials you need to enable it in the tool. There is “Export Materials” option in the second tab “Materials”. If you have enabled it already but you model still does not work, please attach it and we will have a look.

    Regards.

    Carlos.

    #55385

    edwind
    Member

    Thank you for your reply.

    ‘Export Materials’ was checked and I have now edited the Colors to appear somewhere near correct so that it looks fine in PVRShaman. However, when I import the POD file into Zapworks Studio, the whole thing appears a a white graphic. You can download the pod file here http://entiredesign.biz/podfile/

    I really appreciate your help with this.

    Edwind

    #55390

    Hi Edwind,

    I cannot download the pod file from that location above. If it is not very big maybe you could attach it to this thread, or send it to us through our private ticketing system: https://pvrsupport.imgtec.com/
    Does your object have proper mapping and are you exporting the UVs as well?

    Regards

    Carlos.

    1 user thanked author for this post.
    #55391

    edwind
    Member

    Hi Carlos,

    I did try to attach the pod file but the system wouldn’t allow me because it was not in the allowed file type list. I will try to send it to the link you provided.

    I’m afraid I do not understand what you mean by ‘proper mapping’ or ‘UVs’.

    Edwin

    #55392

    Hi Edwin,

    When you apply a material to a mesh, you need to map it to the mesh. In other words, to wrap it correctly so each vertex in the mesh has coordinates into the material surface. These 2d coordinates are called UV and need to be exported accordingly per vertex. Objects created in Blender have UV mapping. You can see/edit them through the Mesh-> UV Unwrap… dialog. When exporting you need to remember to select UVs to be exported as well.

    Regards.

    Carlos.

    #55393

    edwind
    Member

    Thanks again Carlos,

    I will have a look at the details. I went to the link you gave me for attaching a file but it seems my login details don’t work there. Maybe I would have to have another sign in for ticket support.

    Edwind

    #55394

    Hi Edwind,

    Yes, sadly you cannot use your forum credentials in our ticketing system.

    Regards.

    Carlos.

    #55396

    edwind
    Member

    Hi Carlos,

    As I have six objects (each on their own layer) coloured – not textured – I set about Unwrapping them one by one and exporting the .png file for each. Bizarrely, three of the six upon implementing the ‘unwrap’ command, would not appear in the UV/ImageEditor window and so have nothing to export for those three. What can be wrong?

    Edwind

    #55400

    Hi Edwind,

    How are coloring the meshes? Vertex painting is not a standard technique and it is slightly difficult.
    If you want only a flat color for you whole mesh, you do not need to worry about UV or mapping, but you need to apply the color through a material.
    For example, in Bleder, create a sphere, go to Properties and create a new material for this mesh. In the Diffuse tab (the first one) choose a color. You will see now the sphere is colored. Export this sphere with PVRGeoPOD, enabling vertex colors, disabling UV mapping and enabling Export Material in the Material tab. Once exported. load it with PVRShaman and it should look identical as in Blender, properly colored.

    Let me know if this simple approach works for you.

    Regards

    Carlos.

    #55404

    Hi Edwind,

    I think you replied directly to the forum notification so it has not been registered here.
    To disable UVs and enable vertex colors you do it in the first screen of PVRGeoPOD where there is a big table with all the elements to export per vertex. If you scroll down you should be able to see the options for “Colour” and “Exporting mapping channels”. Enable “Colours”.

    Regards.

    Carlos.

    #55405

    edwind
    Member

    Hi Carlos,

    Thanks you for all your suggestions. I have tried them all now and still, the colour of one of the six objects does not appear correctly when the POD file opens in PVRShaman. When the file is imported to Zapworks, all objects are white and devoid of the prescribed colours in the project.

    As POD files are not in the allowed ‘upload list’ below, I will now register and try to upload the file to the other link you gave me, for your perusal.

    Edwind

    #55407

    Hi Edwind,

    I believe Zapworks requires UVs and proper mapping and it might not support vertex colouring. Check their documentation for instructions.
    If this is the case, I would recommend you to create 8×8 flat color texture and apply them to your meshes. This should do the trick with Zapworks.

    Regards.

    Carlos.

Viewing 13 posts - 1 through 13 (of 13 total)
You must be logged in to reply to this topic.