PVRGeoPod: Dae -> Pod conversion loses animation keyframes – Any ideas?

This topic contains 2 replies, has 2 voices, and was last updated by  iellis 3 years, 6 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #31724

    iellis
    Member

    I have a .dae file with a 150 keyframe animation. I can view the animation in a variety of packages and see the data in plain text.

    After exporting, the animation exists in the .pod, but has only one keyframe. I see this same result in PVRShaman or if I load the .pod file in Cocos3D. I’ve tried changing the indexed animation setting. I’ve tried exporting different Collada versions. No luck.

    Does anyone have any magical solutions or even ideas I could try? Thanks!

    #38776

    Joe Davis
    Member

    I’ve spoken to the PVRGeoPOD lead engineer, and he’s told me that the COLLADA specification doesn’t specify a naming convention for animations. It may be the case that PVRGeoPOD doesn’t recognise the animation names in your DAE.

    It’s also possible that the animations are represented in an unusual way that PVRGeoPOD doesn’t support.

    If you can send us a DAE to reproduce the issue with, we can investigate the cause. You can share files with us confidentially by attaching them to a support ticket: https://pvrsupport.imgtec.com/new-ticket

    Thanks,
    Joe

    #38777

    iellis
    Member

    Thanks, Joe! I will open a ticket.

Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.