PVRGeoPod, exporting an animation in Maya

This topic contains 3 replies, has 3 voices, and was last updated by  Scott 8 years, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #29848

    We’re having problems exporting an animation created in Maya into a POD file.  The model shows up fine in our program and in PVRShaman, but it’s just not animating.  PVRShaman is showing the correct number of frames (0-15), but they all look like frame zero.  Any idea what we’re missing or doing wrong?

    Thanks

    #33203

    Gordon
    Moderator

    Hi,

    It’s difficult to tell without a bit more information, e.g. which versions of the exporter, Maya and PVRShaman are you using? Is your model skinned?

    Would you be happy to send the POD and/or the Maya file to devtech @ imgtec.com for us to investigate further?

    #33204

    Thanks for any help you can give.  These are the versions we’re using:

    PVRGeoPOD_2.04.24.0838.zip

    PVRShaman_2.04.24.0811.msi

    Maya 2008

    I think we’re just not selecting the right stuff in Maya when exporting, but I’m not sure.  Note, we have gotten this to work in the past, but that was about a year ago with with older versions of PVRGeoPOD and Maya, and nobody can remember exactly how they did it.  I’m looking into whether we can send the files to you.  For now, here’s the header of the POD file:

    bFixedPoint=0
    bFlipTextureV=0
    bIndexed=1
    bInterleaved=1
    bSortVtx=1
    bTangentSpace=1
    cS=2
    dwBoneLimit=8
    ePrimType=0
    eTriSort=3
    exportBoneGeometry=0
    exportControllers=1
    exportGeom=1
    exportMatrices=1
    exportMappingChannel=1
    exportMaterials=1
    exportNormals=1
    exportObjectSpace=1
    exportSkin=0
    exportSplines=0
    exportVertexColor=0
    fTangentSpaceVtxSplit=0.000000e+000
    psVcOptUVW[0].eType=1
    psVcOptUVW[0].nEnable=135
    psVcOptUVW[1].eType=1
    psVcOptUVW[1].nEnable=135
    psVcOptUVW[2].eType=1
    psVcOptUVW[2].nEnable=135
    psVcOptUVW[3].eType=1
    psVcOptUVW[3].nEnable=135
    psVcOptUVW[4].eType=1
    psVcOptUVW[4].nEnable=135
    psVcOptUVW[5].eType=1
    psVcOptUVW[5].nEnable=135
    psVcOptUVW[6].eType=1
    psVcOptUVW[6].nEnable=135
    psVcOptUVW[7].eType=1
    psVcOptUVW[7].nEnable=135
    staticFrame=0
    sVcOptBin.eType=1
    sVcOptBin.nEnable=135
    sVcOptBoneInd.eType=2
    sVcOptBoneInd.nEnable=15
    sVcOptBoneWt.eType=1
    sVcOptBoneWt.nEnable=15
    sVcOptCol.eType=5
    sVcOptCol.nEnable=15
    sVcOptNor.eType=1
    sVcOptNor.nEnable=135
    sVcOptPos.eType=1
    sVcOptPos.nEnable=135
    sVcOptTan.eType=1
    sVcOptTan.nEnable=135

    #33205

    Scott
    Moderator

    Hi,

    < ?: prefix = o ns = "urn:schemas-microsoft-com:office:office" /> 

    I can’t see anything obviously wrong with your export settings. How are you animating your mesh? It didn’t seem like it from the .pod file you supplied but if you are using skinning then you will need to tick the ‘export skin modifiers’ option and set the bone indices to ‘unsigned byte’. If you have animated the vertices then I’m afraid vertex animation isn’t supported by the pod format.

     

    If you can also send us your Maya scene we may be able to find the exact cause.

     

    Thanks,

     

    Scott

    Scott2009-07-09 10:34:49

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.