PVRGeoPOD with Blender 2.63

This topic contains 3 replies, has 3 voices, and was last updated by  Glidos 5 years, 4 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #30870

    Toxikman
    Member

    PVRGeoPOD x64 v1.29 (SDK build 2.10@869778) MacOS 10.6

    I’m having an issue exporting with this addon. After choosing some basic export options in the dialog, the python script reports the following issue:

    Code:
    *****
    Error: An exception has been raised in the python script
    ‘Mesh’ object has no attribute ‘faces’
      File “/Users/toxikman/Library/Application Support/Blender/2.63/scripts/addons/PVRGeoPODScript.py”, line 751, in AddScene
        AddObject(pvrgeopod, obj, -1)
      File “/Users/toxikman/Library/Application Support/Blender/2.63/scripts/addons/PVRGeoPODScript.py”, line 660, in AddObject
        id = AddMesh(pvrgeopod, obj, parentID)
      File “/Users/toxikman/Library/Application Support/Blender/2.63/scripts/addons/PVRGeoPODScript.py”, line 315, in AddMesh
        for face in mesh.faces:
    *****
    Export failed
    Changing the options doesn’t seem to fix it, even if I say to not export geometry.
    #35835

    Scott
    Moderator

    Hi,

     
    Seems the Blender API for 2.63 has changed. We’ll update the script in our next release to support 2.63. For the moment if you edit the script so
     
    mesh.faces becomes mesh.tessfaces
    mesh.uv_textures becomes mesh.tessface_uv_textures
    mesh.vertex_colors becomes mesh.tessface_vertex_colors
     
    add add
     
    mesh.calc_tessface()
     
    at some point before line 315 and after line 295 your export may be successful.
     
    Cheers,
     
    Scott
    #35836

    Glidos
    Member

    I just tried those changes and PVRGeoPOD disappeared from the Export menu, just as though it was no longer enabled in prefs. I went into prefs and it was enabled, but if I disabled it, Blender then wouldn’t allow me to reenabled it. Blender looks to be detecting a problem with the script even without running it.

    Here’s the changed file: http://intranet.glidos.net/~paul/PVRGeoPODScript.py

    Can anyone see what I’ve done wrong?

    Cheers,
        Paul.

    #35837

    Glidos
    Member

    Sorted. I had a tab in a file that mostly used spaces.  Yes, all looks to work now with those changes made. I haven’t tried any of my models that involve bone animations yet, but everything else looks ok. One of my materials came out strangely, but that may be that I messed something up in blender.

    I’ve updated the file linked above with the working version.

    Thanks for the continued suppoet of PVRGelPOD.

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.