PVRGeoPOD/3dsmax9 exporter bug

This topic contains 8 replies, has 5 voices, and was last updated by  rbgames 8 years, 2 months ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #29757

    gfm
    Member

    It appears the PVRGeoPOD/3dsmax9 exporter doesn’t export vertex colors correctly. It drops the blue and alpha color channels, only exporting red and green. I tried a variety of export modes for color (ARGB/RGBA/float/etc) and all exhibit the same behavior.

    gfm2009-04-05 07:17:05

    #32908

    Gordon
    Moderator

    This is being covered by email as mentioned in the thread here: https://www.imgtec.com/forum/forum_posts.asp?TID=287&PID=1008#1008

    #32909

    gfm
    Member

    The thread you’re referencing is a separate issue… sorry I wasn’t clear. I didn’t know the exporter changed so significantly between 2.02 and 2.04. This thread is for color export problems with the 2.02 exporter.

    #32910

    gfm
    Member

    Files that repro the problem have been emailed to devtech@imgtec.com

    #32911

    Scott
    Moderator
    gfm wrote:
    Files that repro the problem have been emailed to devtech@imgtec.com

     

     

    Hi,

     

    Re-exporting your colourful cube with plug-in 2.02.22.0755 using ARGB for colour works fine for me in my test app. I’m using Max 2008, which version are you using? Also, what values are you passing to glColorPointer?

     

    Thanks,

     

    Scott
    #32912

    gfm
    Member

    I’m using Max 9. Maybe that’s the problem?

    I observed the A and B channels weren’t exporting properly by looking at the binary data in memory (after of course, many hours thinking I wasn’t setting up glColorPointer correctly). In ARGB white exports as 0x00FFFF00. In my example the blue vertices are exported as transparent black, 0x00000000.

    #32913

    ElCheM0
    Member

    Hi,
    I have the same problem with 3dsmax 9, I have to export the model to collada then extract the vertex color and insert in the POD file.

    #32914

    Gordon
    Moderator

    I believe work on this issue is ongoing, but it should be improved in one of our next releases.

    #32915

    rbgames
    Member

    Is this resolved, we are using vertex colors extensively in our title and we need them to export properly.

    If not in the exporter then does someone have some code to loop over the vertex color data in the PODMesh and fix it?

    Thanks,

    RBGames

Viewing 9 posts - 1 through 9 (of 9 total)
You must be logged in to reply to this topic.