PVRShaderEditor shaders file extensions

This topic contains 4 replies, has 3 voices, and was last updated by  Joe Davis 3 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #31861

    Slion
    Member

    Hi,

    I’m working on a project where fragment shaders have a .frag extension and vertex shaders have a .vert extensions.
    My fragment shaders are recognized and compiled nicely but my vertex shaders are not.
    I’m thinking this must be an issue with the file extension.
    When looking at one of my .vert In the bottom left corner on the Settings tab I can change file type from “Custom commandline” to “GLSL ES Vertex Shader” but this has no effect. If I switch file and come back it is set back to “Custom commandline”.
    Is there a way to tell PVRShaderEditor that .vert are vertex shaders?

    Cheers,
    S.

    #39103

    adragos
    Member

    Hi,

    Same thing happens for me too, for .vsh files (GL ES vertex shaders). The .fsh files work just fine.
    I have installed PowerVR SDK 3.4 on Windows7 and OS X 10.9.5 and encountered this problem on both systems.

    Thanks!

    #39104

    Joe Davis
    Member

    With the latest version (PVRShaderEditor 2.5 (SDK build 3.4@3197997)), I’ve not been able to reproduce the issue with .vert or .vsh vertex shader files.

    It’s possible that the problem is caused by corruption in the PVRShaderEditor configuration file. This FAQ item explains how to backup your existing configuration and roll the application back to it’s default state. Please try this workaround and let us know if it resolves the problem for you. If it does fix it, please send us your old, corrupt .plist file for investigation.

    Thanks,
    Joe

    #39105

    adragos
    Member

    Hi,

    I’ve removed the .plist files, tried again and the same problem occurs, on both Windows and OSX.

    Any other ideas?

    Thanks,
    Dragos

    #39106

    Joe Davis
    Member

    Hi,

    The tool auto detects the shader type (vertex, fragment or compute) based on file extension. The auto-detected type is then used when executing the profiling compiler. We’ve found a bug in PVRShaderEditor and suspect it’s responsible for the issues you are seeing (bug report BRN52045). It’s currently not possible to override the auto-detected shader type by changing the selection in the Setting widget’s Filetype dialog. In a future release, this drop-down will override the auto-detected type.

    Thanks,
    Joe

Viewing 5 posts - 1 through 5 (of 5 total)
You must be logged in to reply to this topic.