PVRTexLib crashing

This topic contains 6 replies, has 2 voices, and was last updated by  Tobias Hector 5 years, 5 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #30801

    I have a case when Transcode to PVRTC4 crashes reproducible while compressing the image.

    Crashed Thread: 42

    Exception Type: EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_INVALID_ADDRESS at 0x000000007fd04f7f

    VM Regions Near 0x7fd04f7f:

        MALLOC_TINY            000000007f800000-000000007fb00000 [ 3072K] rw-/rwx SM=PRV

    –>

        __TEXT                 000000008fe7c000-000000008feaf000 [ 204K] r-x/rwx SM=COW /usr/lib/dyld

    Application Specific Information:

    objc[1146]: garbage collection is OFF

    Thread 42 Crashed:

    0   de.code-and-web.TexturePacker      0x002a7e0e CreateCandidatesFromStats + 1838

    1   de.code-and-web.TexturePacker      0x002a1802 RunAGenerateStatsSetThread + 10322

    2   libsystem_c.dylib                  0x936f9ed9 _pthread_start + 335

    3   libsystem_c.dylib                  0x936fd6de thread_start + 34

    #35656

    Hi Andreas,

    Would it be possible to get a copy of the image? You can either post the image to the forum or send it to devtech@imgtec.com and I’ll be happy to take a look at what’s going on 🙂

    Thanks,

    Tobias

    #35657

    Just sent it by mail. Hope it reaches you since it is 10mb.

    #35658

    Hmm, that should be fine, it might just take a while to get here I guess! I’ll take a look once it’s arrived. Thanks!

    #35659

    any update?

    #35660

    It looks like it’s a compressor bug, rather than any of the intermediate code – so I’m just waiting on the pvrtc team to give me a fresh drop of the compressor. I’m not sure yet what it is about this particular image that causes the crash. I’ll let you know whether the new code fixes the issue or not when i’ve got it integrated – but this is likely to take a few days at this point.

    Tobias2012-04-02 09:27:02

    #35661

    Hi Andreas,

    There’s a new version of PVRTexTool available on the website now which fixes this issue. Sorry it took so long! Let me know if you have any further problems.

    Thanks,

    Tobias

Viewing 7 posts - 1 through 7 (of 7 total)
You must be logged in to reply to this topic.