PVRTexTool CL bug OS X version

This topic contains 1 reply, has 2 voices, and was last updated by  Gordon 8 years ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29984

    willyrc
    Member

    Hello,

    I’m trying to encode a RGBA 32bit PNG into 1555 PVR format.

    The command line I’m using is similar to this:

    ./PVRTexTool -f1555 -ioriginal.png -opvr_version.pvr

    The problem I’m having is that the alpha channel values of the PVR texture are always set to 0. The RGB values are encoded fine.

    I tried converting the image using the graphical version of PVRTexTool and it works correctly (Opaque = 255, transparent = 0).

    Any suggestions are appreciated

    William

    #33547

    Gordon
    Moderator

    Hi, as you’ve seen in another post this bug has come up before.

    I installed the command line version of the tool from the separate download on the website from here: https://www.imgtec.com/powervr/insider/powervr-pvrtextool.asp. This produced a correct texture using a line like above. Unfortunately, I’ve just discovered that the GUI from this package won’t decompress them correctly so it appears that they’re still broken when viewing in the program. The development version of PVRTexTool GUI displays them correctly since I applied the last fix and doesn’t seem to have this issue at all.

    This is a bit perplexing for me as I really thought I’d backported the correction fine…

    I’m guessing that the reason the GUI appears to work correctly for you is because you’ve selected an OpenGL/OpenGL ES tab when choosing the format. This is equivalent to using -fOGL1555 from the command line which is treated as a separate format with a separate code path and doesn’t have this issue. Another obvious workaround is to use this option (-fOGL1555 instead of -f1555).

    So the good news is that your textures should be encoded correctly; the bad news is that you can’t view them in the GUI correctly 🙁 I will fix this, but I don’t know if we’ll do another maintenance release before next year. If it is critical to your work path please post further.

Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.