PVRTexToolCL bugs?

This topic contains 1 reply, has 2 voices, and was last updated by  Tobias Hector 4 years, 8 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31231

    I can’t seem to get a few things working running the command line versions of PVRTexTool. (version 3.40). Happens on both Mac and Windows.

    >PVRTexToolCL.exe -square + -f PVRTC1_4 -o temp.pvr -i temp.png
    Errors occurred.

    Whilst trying new version of PVRTexTool, found these errors:
    Error: Non-Power of Two PVRTC1 textures are not supported.
    Attempted to use the legacy interface, but found errors here too:
    Please supply a valid texture format.

    Also flip y,flag doesn’t seem to actually flag (unless I’m remembering this from a previous point in time).

    If I remember correctly there were some other options I had issues with along the way.

    Am I making a blunder or is the square flag not working?

    #37076

    Hi Mysticcoder,

    -square doesn’t actually set the texture to be POT as well, there’s now a separate -pot function which does this. So for your command line, you’ll need to use:
    PVRTexToolCL.exe -square + -pot + -f PVRTC1_4 -o temp.pvr -i temp.png

    FYI, it’s worth noting that in the old version of the command line, -square did in fact make the texture power of two as well. So I guess that’s what you were thinking of?

    -flip y,flag didn’t work in the initial release of the new command line, but it should work in the most recent versions. If you find this to not be the case let me know.

    If you have any other problems with the command line please don’t hesitate to ask!

    Thanks,
    Tobias

Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.