PVRTrace: “DisableBinaries”

This topic contains 4 replies, has 2 voices, and was last updated by  Dark_Photon 1 year, 7 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #53420

    Testing with PVRTrace in the 2016 R1.1 SDK (Recorder Version: 16.1@3980846), I noticed my glProgramBinary calls failing again. I also noticed this note emitted by the recorder lib:

    PVRTrace has disabled support for shader/program binaries in the API. This can be changed by setting DisableBinaries to false in the config.

    First, to verify which section I should add it to, I checked the PVRTrace User Manual. That setting isn’t listed. You might add that.

    Second, I went ahead and added it to the “Tracing” section:

    “DisableBinaries”: false

    and it didn’t make any difference. All of my glProgramBinary calls (which work under PVRVFrame w/o trace) are still throwing GL_INVALID_ENUM, and I still see the “PVRTrace has disabled support for shader/program binaries…” message on startup of the recorder libs.

    What’s the procedure for enabling program binary support through PVRTrace?

    Thanks.

    #53438

    Joe Davis
    Member

    Hi Dark_Photon,

    I’ve checked the PVRTrace config parser. I’m not sure why it’s ended up there, but the DisableBinaries flag needs to be given in our internal debugging group rather than one of the publicly documented ones. if you add it to an “Internal” section, the option should work for you.

    I’ve reported BRN59352 in our tracker to move this flag to the Tracing group and to document it in the user manual.

    #53466

    Thanks, Joe! That works well.

    (By the way: The RSS feed for these forums broke early-to-mid last week. Sent a site mail, but hadn’t heard anything back. Is there a forums appropriate to post questions/problems like this? For details on the breakage, see:

    * http://www.rssboard.org/rss-validator/check.cgi?url=http%3A%2F%2Fcommunity.imgtec.com%2Fforums%2Fcat%2Fpowervr-insider-graphics%2Ffeed
    “line 161, column 195: XML parsing error: <unknown>:162:0: unclosed CDATA section [help]”

    vs. for example:
    * http://www.rssboard.org/rss-validator/check.cgi?url=https%3A%2F%2Fcommunity.arm.com%2Fcommunity%2Ffeeds%2Fallcontent%3Fcommunity%3D2243

    #53479

    Joe Davis
    Member

    Glad to hear that worked 🙂

    Thanks for pointing out the RSS issue. I didn’t realise until the web team told me about your report. Everything seems to be working now.

    #53498

    The RSS feed looks good now — thanks guys!

Viewing 5 posts - 1 through 5 (of 5 total)
You must be logged in to reply to this topic.