PVRVFrame bugs

This topic contains 0 replies, has 1 voice, and was last updated by  Michele 6 years, 3 months ago.

Viewing 1 post (of 1 total)
  • Author
    Posts
  • #30566

    Michele
    Member

    Hi I would like to report what seem to be a couple of bugs in the PVRVFrame emulator build 2.08.28.0634. I am testing OpenGL ES 1.1 under Win7 64bit (GeForce 460M) using “SGX (OGLES1,OGLES2)” profile and the following happens:

    – GL_OES_texture_cube_map is exposed but none of the relative function pointers are available, i.e. glTexGenfOES and the others are all NULL. Also enabling GL_TEXTURE_GEN_STR_OES returns invalid enum. It’s strange this feature is not present because it should be quite simple to emulate on desktop OpenGL even if the semantic is slightly different. Is there a particular reason not to support this extension on the emulator?

    – Has_GL_OES_blend_func_separate is exposed but glBlendFuncSeparateOES is NULL. Is there any particular reason why this function is not supported by PVRVFrame? It’s seems to me it should be straightforward to emulate it given the host GL implementation supports it, isn’t it?

    Minor ones:

    – GL_OES_fixed_point is exposed but its functions are not exposed with their OES suffix, i.e. glAlphaFuncxOES shoud return the same address of glAlphaFuncx I guess.

    – GL_OES_single_precision is exposed but again its functions are not exposed with their OES suffix, i.e. glDepthRangefOES shoud return the same address of glDepthRangef I guess.

    Thank you,

    Michele

Viewing 1 post (of 1 total)
You must be logged in to reply to this topic.