PVRVFrame – Why is the console output in Polish?

This topic contains 1 reply, has 2 voices, and was last updated by  Joe Davis 6 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30505

    I have an OpenGLES 2 application that I’ve compiled on both Linux and Mac OS X using PVRVFrame’s emulation libraries, and I get console output in Polish:

    Biblioteki sciezka: /usr/local/lib/libEGL.dylib
    dlopen tries: libGL.dylib
    dlopen tries: /usr/X11/lib/libGL.dylib
    vendor/shl: Imagination Technologies (Host GL: `NVIDIA Corporation`)
    vendor/shl: OpenGL ES 1.1 ( SDK build: 2.08.28.0607)2.1 NVIDIA-1.6.26`)
    bufek withs es1 exts: OGLES1 EXTENSIONS: GL_OES_byte_coordinates GL_OES_fixed_point GL_OES_single_precision GL_OES_matrix_get GL_OES_read_format GL_OES_compressed_paletted_texture GL_OES_point_sprite GL_OES_point_size_array GL_OES_matrix_palette GL_OES_draw_texture GL_OES_query_matrix GL_IMG_read_format GL_IMG_texture_compression_pvrtc GL_IMG_texture_format_BGRA8888 GL_OES_texture_env_crossbar GL_OES_texture_mirrored_repeat GL_OES_blend_subtract GL_OES_blend_func_separate GL_OES_blend_equation_separate GL_OES_stencil_wrap GL_OES_extended_matrix_palette GL_OES_stencil8 GL_OES_rgb8_rgba8 GL_OES_depth24 GL_OES_texture_cube_map GL_OES_compressed_ETC1_RGB8_texture GL_OES_mapbuffer GL_EXT_multi_draw_arrays GL_OES_framebuffer_object
    vendor/shl: Imagination Technologies (Host GL: `NVIDIA Corporation`)
    vendor/shl: OpenGL ES 2.0 ( SDK build:  2.08.28.0607) 2.1 NVIDIA-1.6.26`)
    vendor/shl: OpenGL ES GLSL ES 1.00 ( Host GL: `1.20`)
    Egl scizka: libEGL.dylib
    Egl scizka2: /usr/local/lib/libEGL.dylib[/CODE]

    When I saw it on Linux, I just thought I must have misconfigured my environment somehow, although setting the LC_ALL, LANG, and LANGUAGE environment variables made no difference.  Now that I see the problem on Mac OS X as well, I find it unlikely that the bug is the fault of my machines.

    Is this a bug in PVRVFrame?

    [CODE]Biblioteki sciezka: /usr/local/lib/libEGL.dylib
    dlopen tries: libGL.dylib
    dlopen tries: /usr/X11/lib/libGL.dylib
    vendor/shl: Imagination Technologies (Host GL: `NVIDIA Corporation`)
    vendor/shl: OpenGL ES 1.1 ( SDK build: 2.08.28.0607)2.1 NVIDIA-1.6.26`)
    bufek withs es1 exts: OGLES1 EXTENSIONS: GL_OES_byte_coordinates GL_OES_fixed_point GL_OES_single_precision GL_OES_matrix_get GL_OES_read_format GL_OES_compressed_paletted_texture GL_OES_point_sprite GL_OES_point_size_array GL_OES_matrix_palette GL_OES_draw_texture GL_OES_query_matrix GL_IMG_read_format GL_IMG_texture_compression_pvrtc GL_IMG_texture_format_BGRA8888 GL_OES_texture_env_crossbar GL_OES_texture_mirrored_repeat GL_OES_blend_subtract GL_OES_blend_func_separate GL_OES_blend_equation_separate GL_OES_stencil_wrap GL_OES_extended_matrix_palette GL_OES_stencil8 GL_OES_rgb8_rgba8 GL_OES_depth24 GL_OES_texture_cube_map GL_OES_compressed_ETC1_RGB8_texture GL_OES_mapbuffer GL_EXT_multi_draw_arrays GL_OES_framebuffer_object
    vendor/shl: Imagination Technologies (Host GL: `NVIDIA Corporation`)
    vendor/shl: OpenGL ES 2.0 ( SDK build:  2.08.28.0607) 2.1 NVIDIA-1.6.26`)
    vendor/shl: OpenGL ES GLSL ES 1.00 ( Host GL: `1.20`)
    Egl scizka: libEGL.dylib
    Egl scizka2: /usr/local/lib/libEGL.dylib[/CODE]

    When I saw it on Linux, I just thought I must have misconfigured my environment somehow, although setting the LC_ALL, LANG, and LANGUAGE environment variables made no difference.  Now that I see the problem on Mac OS X as well, I find it unlikely that the bug is the fault of my machines.

    Is this a bug in PVRVFrame?

    #34864

    Joe Davis
    Member

    Hi James,

    Thanks for reporting this issue. This issue is with one of our engineers, and has been entered in our bug tracker as BRN33282. The output should be entirely in English in all of our utilities and tools, so this is not the result of localization issues on your system/s.

    We will ensure this issue is resolved in a future release.

Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.