Samsung Galaxy Tab 2 (SGX540) freeze/reboot

This topic contains 4 replies, has 2 voices, and was last updated by  Joe Davis 5 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #30921

    rknoesel
    Member

    Hello.  One of our apps (Riptide GP), which has been out for a while now (1 year+), is experiencing a system freeze followed by an automatic reboot on a Galaxy Tab 2 (7.0) with the SGX 540 (Model GT-P3113, Android 4.0.3).  Nothing shows up in logcat.  The issue does not appear when rendering is disabled.  This game is stable across a vast number of devices.

    This issue is very reproducible (happens within 5 minutes during the demo/attract loop).  We’re happy to send an APK for analysis.
    Any advice?
    Thanks!
    #36006

    Joe Davis
    Member

    Hi,

    Can you check the GPU driver version for this platform (cat /proc/pvr/version)? Have you seen the same problem on any other devices, e.g. the original Galaxy S?

    We don’t have a Galaxy Tab 2 in our office, but if we can find out the GPU driver version number then we may be able to find another platform that we can reproduce the bug on.

    Thanks,
    Joe

    #36007

    rknoesel
    Member
    Hi Joe,
    Here’s the content of /proc/pvr/version:
    cat /proc/pvr/version
    Version CustomerGoogle_Android_ogles1_ogles2_GPL sgxddk 18 1.8@785978 (release) omap4430_android
    System Version String: SGX revision = 1.2.0

    So far we have not seen this issue on other PowerVR devices.

    Cheers,
    Ralf
    #36008

    rknoesel
    Member
    Joe,
    Today an OTA update became available for the Galaxy Tab 2, which upgraded the OS from 4.0.3 to 4.0.4  (no change in GPU driver version).  This seems to have fixed the problem, as we have now soaked for 4 hours or so without the issue occurring.
    I suppose this is good news, but a bit unsettling at the same time.  At least we can now respond with a suggested fix to the support emails.
    Cheers,
    Ralf
    #36009

    Joe Davis
    Member

    Hi Ralf,

    I’m glad to hear the OTA update resolved the issue. If the driver version hasn’t changed, then the problem may be specific to the Galaxy Tab 2 4.0.3 Android image. If you encounter this issue on any other platforms, let us know and we’ll look into it for you 🙂

    Thanks,
    Joe

Viewing 5 posts - 1 through 5 (of 5 total)
You must be logged in to reply to this topic.