skinned & non skinned mesh in same POD file

This topic contains 1 reply, has 2 voices, and was last updated by  Scott 7 years, 11 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29965

    fgrgtr
    Member

    Hi,

    I created a Max scene with severals meshes
    One of them is skinned.
    I export the scene in a unique POD ( with skin settings )

    I am using a shader adapted for skinning (like skinning sample).

     

    In the c++ part, i have two method to draw the mesh :
    1) a skinned drawmesh  ( from skinning sample)
    2) a standard rendering ( from POD basic sample)

    and i switch beetween meshdraw method in function of batch number in the mesh’s node.

    The result is strange :
    there is only skinned mesh at screen. ( with background clear color )  

     – If i delete the skinned mesh from the scene, the same code produce a correct rendering for standard objects
     
    I test several things. and it seems that as soon as , i draw skinned mesh ( only one time ) , the futurs rendering will not contains the standards meshes.

    Is there somebody have an idea ?

    Regards

    The rendering result is

    #33489

    Scott
    Moderator
    fgrgtr wrote:
    Hi,

    I created a Max scene with severals meshes
    One of them is skinned.
    I export the scene in a unique POD ( with skin settings )

    I am using a shader adapted for skinning (like skinning sample).

     

    In the c++ part, i have two method to draw the mesh :
    1) a skinned drawmesh  ( from skinning sample)
    2) a standard rendering ( from POD basic sample)

    and i switch beetween meshdraw method in function of batch number in the mesh’s node.

    The result is strange :
    there is only skinned mesh at screen. ( with background clear color )  

     – If i delete the skinned mesh from the scene, the same code produce a correct rendering for standard objects
     
    I test several things. and it seems that as soon as , i draw skinned mesh ( only one time ) , the futurs rendering will not contains the standards meshes.

    Is there somebody have an idea ?

    Regards

    The rendering result is

     

    Hi,

     

    It sounds like a renderstate or something along those lines is getting changed in the function that draws the skinned mesh which is having an adverse effect on the rendering of non-skinned meshes. The simplest way to debug this is to comment out the draw skinned mesh function and then re-add the contents bit by bit to determine where the problem is.

     

    Thanks,

     

    Scott
Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.