something went wrong, when I downloaded program to the MIPSfpga core

This topic contains 3 replies, has 3 voices, and was last updated by  Hazel 1 year, 3 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #54065

    Ken
    Member

    I wrote a small prog and “make” then used the blaster load to MIPSfpga. When it finished, it showed
    Error: fast_data (0x80000000) is within write area (0x80000000-0x80000086).
    Error: Change work-area-phys or load_image address!
    I don’t know what’s wrong with it and how to get it fixed. If you just got any idea please tell me as soon as possible.Thanks.

    2 users thanked author for this post.
    #54067

    Useful reply from Prof. Chaver-Martinez at UCM:
    “I think that error should not cause OpenOCD/gdb not to work. We suggest to try an example program among those provided with the package (for example “AssemblyExample”). You will probably will obtain the same error but you should be able to debug the program with gdb/OpenOCD.
    In that case, probably there is a problem in the program he wrote.”

    2 users thanked author for this post.
    #54068

    Ken
    Member

    Yes, that’s right. I’ve tried several times before asking the question and the error does occur. I thought that there was sth wrong with my project, but now I don’t have to worry about that. Thanks a lot.
    Well, anyway, I feels somewhat uncomfortable with the little bug…

    #54094

    Hazel
    Member

    Hi..i am a new user here. As per my knowledge its true as said above that the error should not cause OpenOCD/gdb not to work. We suggest to try an example program among those provided with the package . You will probably will obtain the same error but you should be able to debug the program with gdb/OpenOCD

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.