TexTool versus BMP format

This topic contains 1 reply, has 2 voices, and was last updated by  Gordon 8 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #29791

    johnf
    Member

    Hello,
    I ran into an unexpected behavior of PVRTexTool: I found that the format of the .bmp source file affected whether the .pvr texture would work at all.  I used a 128×128 bmp saved from gimp, which defaulted to 24-bit RGB888.  Unfortunately, PVRTexTool creates a .pvr file, but at run time, the texture does not show (all black).  I found that changing the advanced .bmp save options in gimp to 16-bit RGB565 made things work much better.  I used -fOGLPVRTC4 format with no MIP mapping on an omap35x EVM.

    I would have expected an error at some point in the process either from PVRTexTool or at runtime when loading the .pvr, or maybe I missed the doc which said “don’t do that!”.

    Maybe this will save someone else some pain.

    Thanks!
    ,
    John

    #33039

    Gordon
    Moderator

    I can’t reproduce the issue you’ve described here. However, using the GIMP and saving 32bit BMPs results in PVRTexTool reading an image with the colour channels mixed up. Saving as 24bit seems to produce textures as expected. Saving as 565 from GIMP is adding a quality degrading step to your pipeline that seems unnecessary.

    I’ve added a bug BRN 27490 to our system concerning this issue.

    I recommend using PNG textures with PVRTexTool as they allow full 32bit RGBA support, save on diskspace and are heavily tested.

Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.