Trouble to run PVRShaman(2.4) for OpenGL ES3.0 pod file in Mac.

This topic contains 3 replies, has 2 voices, and was last updated by  CarlosSarria 2 months, 3 weeks ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #56502

    DSP
    Member

    Hello, I am very new to PVR tools, so pardon my posting with this trivial issue.
    I just have downloaded PVRShaman (PVRShaman 2.4 (SDK build 16.2@4240979))
    on my MacBook (OS X, 10.12.6, Sierra)
    and tried to load OpenGL ES 3.0 pod file but failed with the following error:

    ===================================================
    The OpenGL version required for OpenGL:ES 3.0 support is too low.
    Required: OpenGL 3.3
    Found: OpenGL 2.1
    ===================================================
    In the preference menu of PVRShaman,
    I chose the OpenGL:ES 3.0 API and selected the compiler
    PowerVR GLSL ES Series6.
    According to the Shaman manual, it supports OpenGL ES 3.0.
    It looks like that I need to upgrade OpenGL version in the PVR package to 3.3, but I have no idea how to do it.
    It must be a trivial fix. Much appreciated in advance.

    #56503

    Hi,

    Your GPU is probably capable of doing OpenGL 4+ but Apple does not make these contexts available so we are limited to the compatibility contexts which do not go higher than 2.1. I think it is somehow possible to access core profiles that will go higher but PVRShaman does not currently support them.
    The OpenGL ES 2.0 profile should work fine on Mac.

    Regards.

    Carlos.

    1 user thanked author for this post.
    #56511

    DSP
    Member

    Thanks, Carlos, for your prompt answer to my question, clarifying the reason for the issue.
    However, I was hoping to see this platform dependent critical details were mentioned somewhere either in the release note or in the manual (pdf, web), somewhere, such that any users/customers could avoid such hassles that I had. Before I went for the ticket submission, I had spent almost half day due to this issue.
    Also, I had found that PVRShaman manual doesn’t mention about its support of OpenGL ES 3.0, (it says 1.0 and 2.0 only), though the information on the web does say it support 3.0. So please update the manual accordingly.

    ==========================
    Chapter 2 Software Description.
    PVRShaman is a tool for the rapid prototyping, development and testing of OpenGL ES 2.0, OpenGL, DirectX9 and DirectX10 shaders.
    ==========================

    Thanks again, Carlos. As you suggested I’d better stay with 2.0 when I use PVRShaman in my Mac platform.

    #56513

    Hi,

    I am sorry if the documentation was not clear on this issue, but it is difficult to have a comprehensive list of supported platforms when it depends on the capabilities of your system: GPU installed, drivers version, etc.
    The error reported by PVRShaman is clear enough about what is the problem, but we will look into enhancing the documentation to make it clearer.
    I have also filed an internal bug (#65568) so we can look into making core profiles available to PVRShaman.

    Best regards.

    Carlos.

Viewing 4 posts - 1 through 4 (of 4 total)
You must be logged in to reply to this topic.