Unable to display text..plz Help

This topic contains 4 replies, has 2 voices, and was last updated by  Scott 8 years, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29912
    Im trying to  display text using  Print3D function. so i just add following lines into my program and also added Image.cpp file into Simplecube.mmp file

     

    const

    char c_szImageTexFile[] = “Image.pvr”;

    void

    CSimpleCube::AppInit( void )

    {

    …………………

    ………………..

    m_Print3D

    .SetTextures(0,iScreenWidth,iScreenHeight, bRotate = false);

    PVRTTextureLoadFromPVR

    (c_szImageTexFile, &m_ui32Texture);

    }

     

    void

    CSimpleCube::AppCycle()

    {

    ………..

    ………..

     

    glEnable(GL_TEXTURE_2D);

    m_Print3D.DisplayDefaultTitle(“IntroducingPVRTools”, “Description”, ePVRTPrint3DLogoPVR);

    m_Print3D.Print3D(8.0f, 30.0f, 1.5f, PVRTRGBA(64, 64, 170, 255), “example”);

    m_Print3D.Flush();

     

    }

     

    this is basically a Nokia symbian opengles example program (simplecube). here i trying to implement powervr coding to  display text reference one of powerVR example (Introduction to PVRTools).

     

    After compile the code program can install successfully into phone.But when i try to run the program in my Nokia N95 only Powevr logo is displaying.but the text is not display. I added image.cpp file in my source folder. the example coding usage pvrshell. but i don’t using pvrshell headers files.So above lines is enough for display text. or any other configaration needed?

     

    I think, my program can’t load the texture(image.pvr). but any other way to load this texture use my above codestyle..

     

    So plz help me about this isssue…

     

    Thanks

    rassall_jubair2009-09-02 08:24:26

    #33376

    Hello…

     

    Untill there is no response abt this issue..I m desperately waiting for usefull comments/response to solve this problem…. after some examination Im little bit sure only following  lines is enogh to display text and even do need image.pvr and c_szImageTexFile, &m_ui32Texture to display only fonts/texts.. 

     

    m_Print3D.DisplayDefaultTitle(“IntroducingPVRTools”, “Description”, ePVRTPrint3DLogoPVR);

    m_Print3D.Print3D(8.0f, 30.0f, 1.5f, PVRTRGBA(64, 64, 170, 255), “Hello”);

    m_Print3D.Flush();

    Here, even logo is displaying but still text not display..what is the problem in my program?

     

    Plz suggest me …

     

     

    Thanks

    Rassall
    #33377

    Scott
    Moderator

    Hi,

     

    I modified Nokia’s SimpleCube example in a very similar way to you and can see the text and logo.

     

    Code:
    void CSimpleCube::AppInit( void )
    {
    ….
           m_Print3D.SetTextures(0, iScreenWidth, iScreenHeight);
    }
     
    void CSimpleCube::AppExit( void )
    {
            m_Print3D.ReleaseTextures();
    }
     
    void CSimpleCube::AppCycle( TInt aFrame )
        {
    ….
        m_Print3D.DisplayDefaultTitle(“IntroducingPVRTools”, “Description”, ePVRTPrint3DLogoPVR);
        m_Print3D.Print3D(8.0f, 30.0f, 1.5f, PVRTRGBA(64, 64, 170, 255), “example”);
        m_Print3D.Flush();
    }

     

    The only difference is my call to SetTextures.

     

    Thanks,

     

    Scott
    #33378
    Scott wrote:
    Hi,

     

    I modified Nokia’s SimpleCube example in a very similar way to you and can see the text and logo.

     

    Code:
    void CSimpleCube::AppInit( void )
    {
    ….
           m_Print3D.SetTextures(0, iScreenWidth, iScreenHeight);
    }
     
    void CSimpleCube::AppExit( void )
    {
            m_Print3D.ReleaseTextures();
    }
     
    void CSimpleCube::AppCycle( TInt aFrame )
        {
    ….
        m_Print3D.DisplayDefaultTitle(“IntroducingPVRTools”, “Description”, ePVRTPrint3DLogoPVR);
        m_Print3D.Print3D(8.0f, 30.0f, 1.5f, PVRTRGBA(64, 64, 170, 255), “example”);
        m_Print3D.Flush();
    }

     

    The only difference is my call to SetTextures.

     

    Thanks,

     

    Scott
     

    Thanks Scott…but i have already add SetTextures in my coding(plz see my1st post) and also noted im trying to implement this text coding using Artoolkitplus s60 for Augmented Reality where camera is on.  

     

    I tried to follow your way to add SetTextures..

     

    m_ Print3D.SetTextures(0,iScreenWidth,iScreenHeight);

     

     

    but result is same…only logo display but text not display yet….but i want to display the text…

     

    so, how we can solve this?plz suggest me..

     

    Thanks…

     

     

     

    rassall_jubair2009-09-24 15:37:33

    #33379

    Scott
    Moderator
    rassall_jubair wrote:
    so, how we can solve this?plz suggest me..
     

    The above code snippets were the only changes I made to simplecube to get print3D to work. If you send your code to devtech@imgtec.com we can take a look and compare it with my changes to see if we can figure out your problem.
Viewing 5 posts - 1 through 5 (of 5 total)
You must be logged in to reply to this topic.