We’re trying to record from the Line In, without success

Tagged: ,

This topic contains 1 reply, has 1 voice, and was last updated by  alastair 4 years, 11 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #30982

    alastair
    Moderator

    We use the latest Meta Linux distribution (supplied as part of Minimorph_1_0-rel007-full.tar.gz file) and face a problem while the accessing analogue audio devices. I mean the old-style line input/headphone output, not the HDMI audio. In particular, “aplay -L” command only lists the digital HDMI audio, but not the analogue one.

    #36175

    alastair
    Moderator

    In order to get sound out of the headphone output socket, you must disable HDMI Audio in the kernel configuration.

    You need to alter the kernel config from buildroot.
    Enter

    # make menuconfig ARCH=metag

    Then go into:
    Processor Types and Features >
    Board Support

    Disable > 01SP/01TT HDMI audio out

    Exit, saving changes, then re-make the kernel (make ARCH=metag)

    Load the subsequent kernel – I find the easiest method is to convert to vmlinux.ub (U-Boot) format and place the image on a microSD card.

    You can then record using arecord and aplay.

    If you then try amixer, you should see something like this:

    # amixer
    Simple mixer control 'Master',0
    Capabilities: pvolume penum
    Playback channels: Front Left - Front Right
    Limits: Playback 0 - 255
    Mono:
    Front Left: Playback 255 [100%]
    Front Right: Playback 255 [100%]
    Simple mixer control 'Line/IPOD-In Gain',0
    Capabilities: volume penum
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: 0 - 7
    Front Left: 7 [100%]
    Front Right: 7 [100%]
    Simple mixer control 'Mic-In Gain',0
    Capabilities: volume penum
    Playback channels: Front Left - Front Right
    Capture channels: Front Left - Front Right
    Limits: 0 - 15
    Front Left: 15 [100%]
    Front Right: 15 [100%]
    Simple mixer control 'Input Mux',0
    Capabilities: enum
    Items: 'Mic In' 'Line In' 'Ipod In'
    Item0: 'Mic In'
Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.