What might cause Error “RemoveMapping: no record for pvUserAddress”?

This topic contains 1 reply, has 2 voices, and was last updated by  Tobias Hector 4 years, 6 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #31206

    We have a old product that uses MBX imagination PVR library, and it looks like it has some issues rendering OpenGL graphics to display.
    I enabled some debug messages in PVR library code and it looks like it errors in PVRMMAPRemoveMapping(..) function.
    The error that the debug outputs is:
    “RemoveMapping: no record for %p-%p (%d bytes)”, pvUserAddress, pvUserAddress + ui32Length – 1, ui32Length));

    What might be the possible cases for the above error in PVR code.
    This code runs on an OMAP2 processor.

    Thanks for the help!

    #36954

    Hi Tummala,

    This is an old platform now as you’ve said, but I’ll try to answer your questions as best I can! So the chances are that this is an out of memory problem, the most probably cause of this is that earlier in the application some memory was allocated and it failed. The subsequent remove mapping operation has then failed because there’s nothing mapped in the first place. So this is likely the best place to look for problems, checking for out of memory errors etc. What sort of problems are you actually seeing occur within the application?

    It might also be worth contacting TI about this due to it being their chip, but I’d probably investigate the out of memory situation first.

    Hope this helps!
    Regards,
    Tobias

Viewing 2 posts - 1 through 2 (of 2 total)
You must be logged in to reply to this topic.