Segmentation fault !

This topic contains 2 replies, has 2 voices, and was last updated by  chris 1 year, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #54326

    liang
    Member

    Sorry,im a newbie ,Just yesterday I set up across-edit circumstance at Ubuntu x86_64bit, and try to compile a program,But such a problem has emerged:

    Tools Directory:/opt/Imagination/PowerVR_Graphics/PowerVR_Tools
    SDK Directort:/opt/Imagination/PowerVR_Graphics/PowerVR_SDK

    root@liangc-x86-Ubuntu:/home/liangc/Desktop/Link to workspace/opengles3-book-master/Chapter_6/Example_6_3# ./Example_6_3

    WARNING: Config file not found. Tried: pvrtraceconfig.json
    WARNING: Recording Aborted. Exiting.

    So,program is not executed,I think the problem is in the pvrtraceconfig.json file,I don’t know what’s pvrtraceconfig.json and what’s its function ?

    OKAY! I solved it.

    I found it in PVRTrace user manual.PDF

    2.3.3. Linux
    For manual installation on Linux, perform the following steps:
    1. Copy: libEGL.so, libGLESv2.so (OpenGL ES 2.0, 3.0 and 3.1), libGLES_CM.so,
    libGLESv1_CM.so (OpenGL ES 1.1) and libPVRTrace.so to any folder.
    2. Set the LD_LIBRARY_PATH to the folder containing the new libraries. This can be set using
    export LD_LIBRARY_PATH=… and reverted once the trace is complete. Alternatively, this can
    be set by using LD_LIBRARY_PATH=… ./<APPLICATION_NAME> as part of running the
    trace.
    3. If pvrtraceconfig.json does not exist, make one manually (see Section 2.4).
    4. Place pvrtraceconfig.json into the executable folder.
    5. Update pvrtraceconfig.json so that EglLibraryPath, Es1LibraryPath and
    Es2LibraryPath are set to the location of the system‟s graphics libraries (see Section 2.4).

    So,Search all directory and found _SKELETON_CONFIG.json ! and rename and replace……
    OKAY! I solved it.

    but, a NEW PROBLEM has emerged:
    Segmentation fault(core dumped) !

    OKAY! I solved it again!
    see Attachments

    Attachments:
    You must be logged in to view attached files.
    #54329

    liang
    Member

    Attachments:
    You must be logged in to view attached files.
    #54346

    chris
    Moderator

    Hi Liang

    It sounds like you were pointing the application to the PVRTrace libraries by mistake. PVRTrace is a utility for capturing OpenGL ES calls and analysing them.

    Our emulation layer is named PVRVFrame. If you just want to run an OpenGL ES application you should always point to the libraries insider /PowerVR_Tools/PVRVFrame/…

    I hope helps make things clearer

Viewing 3 posts - 1 through 3 (of 3 total)
You must be logged in to reply to this topic.